{"answers":{"affected":"3 open source packages ship an affected version, including plone and Plone. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33926 exists.","fix":"Upgrade plone to 5.2.5 or later.","what":"CVE-2021-33926 is a high-severity server-side request forgery vulnerability in Plone Plone, published on 17 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-33926 and fix it if it is affected.\n\nWhat it is: CVE-2021-33926 is a high-severity server-side request forgery vulnerability in Plone Plone, published on 17 Feb 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-33926 exists.\n\nAffected packages and fixed versions:\n- plone (PyPI): affected from 4.3; fixed in 5.2.5\n- plone (PyPI): affected from 4.3; fixed in 5.2.5\n- Plone (PyPI): affected from 4.3; fixed in 5.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-33926/ (Markdown: https://insights.sbomify.com/CVE-2021-33926/index.md)","id":"CVE-2021-33926","markdown":"https://insights.sbomify.com/CVE-2021-33926/index.md","name":"CVE-2021-33926","record":{"aliases":["GHSA-47p5-p3jw-w78w","PYSEC-2023-289"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Plone CMS","requires_auth":"low_privilege","summary":"Attackers can access sensitive information via the RSS feed portlet in Plone CMS, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plone","vendor":"plone"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"An issue in Plone CMS v. 5.2.4, 5.2.3, 5.2.2, 5.2.1, 5.2.0, 5.1rc2, 5.1rc1, 5.1b4, 5.1b3, 5.1b2, 5.1a2, 5.1a1, 5.1.7, 5.1.6, 5.1.5, 5.1.4, 5.1.2, 5.1.1 5.1, 5.0rc3, 5.0rc2, 5.0rc1, 5.0.9, 5.0.8, 5.0.7, 5.0.6, 5.0.5, 5.0.4, 5.0.3, 5.0.2, 5.0.10, 5.0.1, 5.0, 4.3.9, 4.3.8, 4.3.7, 4.3.6, 4.3.5, 4.3.4, 4.3.3, 4.3.20, 4 allows attacker to access sensitive information via the RSS feed protlet.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Server-Side Request Forgery in Plone CMS","id":"CVE-2021-33926","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"plone:plone","products":["plone:plone"],"type":"ssrf","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Memory corruption in n/a","id":"CVE-2021-33928"},"packages":[{"ecosystem":"PyPI","fixed":["5.2.5"],"introduced":["4.3"],"last_affected":[],"package":"Plone","purl":null,"source":"GHSA-47p5-p3jw-w78w"},{"ecosystem":"PyPI","fixed":["5.2.5"],"introduced":["4.3"],"last_affected":[],"package":"plone","purl":"pkg:pypi/plone","source":"GHSA-47p5-p3jw-w78w"},{"ecosystem":"PyPI","fixed":["5.2.5"],"introduced":["4.3"],"last_affected":[],"package":"plone","purl":"pkg:pypi/plone","source":"PYSEC-2023-289"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2021-33925"},"products":["n/a"],"published":"2023-02-17","related":[{"cvss_score":9.9,"headline":"Incorrect Permission Assignment for Critical Resource in Plone","id":"CVE-2021-33509","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2020-35190","kev_date_added":null,"published":"2020-12-17"},{"cvss_score":9.8,"headline":"Plone Unauthenticated Write Vulnerability","id":"CVE-2020-7941","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":9.3,"headline":"Zope Command Execution Vulnerability","id":"CVE-2011-3587","kev_date_added":null,"published":"2011-10-10"},{"cvss_score":8.8,"headline":"Improper Restriction of XML External Entity Reference in Plone","id":"CVE-2020-28734","kev_date_added":null,"published":"2020-12-30"},{"cvss_score":8.8,"headline":"SSRF attacks via tracebacks in Plone","id":"CVE-2020-28735","kev_date_added":null,"published":"2020-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-03-19","vendors":["n/a"]},"summary":"Attackers can access sensitive information via the RSS feed portlet in Plone CMS, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2021-33926/"}