CVE-2021-3393 Generation of Error Message Containing Sensitive Information in postgresql
Attackers with UPDATE but not SELECT permissions can leak column data via crafted queries causing error messages.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-3393?
CVE-2021-3393 is a medium-severity vulnerability in Postgresql Postgresql, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11. A user having UPDATE permission but not SELECT permission to a particular column could craft queries which, under some circumstances, might disclose values from that column in error messages. An attacker could use this flaw to obtain information stored in a column they are allowed to write but not read.
Weakness: CWE-209
Which versions are affected by CVE-2021-3393?
1 open source package ship an affected version, including postgresql. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
postgresql Bitnami | All versions | 11.11.0, 12.6.0, 13.2.0 |
Linux distribution packages (12)
postgresql12 SUSE:Enterprise Storage 6 | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 12.6-8.16.1 |
postgresql12 SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 12.6-8.16.1 |
postgresql12 SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Manager Proxy 4.0 | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Manager Retail Branch Server 4.0 | All versions | 12.6-3.21.4 |
postgresql12 SUSE:Manager Server 4.0 | All versions | 12.6-3.21.4 |
postgresql12 openSUSE:Leap 15.2 | All versions | 12.6-lp152.3.16.1 |
Products include Postgresql Postgresql, Redhat Enterprise Linux, Redhat Software Collections.
How do I fix CVE-2021-3393?
Upgrade postgresql to a fixed version for your release line: 11.11.0, 12.6.0 or 13.2.0.
Is CVE-2021-3393 being exploited?
There is no known exploitation of CVE-2021-3393 in the wild and no public exploit code.
Other vulnerabilities in Postgresql Postgresql
Sources
Also known as ALPINE-CVE-2021-3393, BIT-postgresql-2021-3393, CLEANSTART-2026-FG88003, DEBIAN-CVE-2021-3393, ECHO-706e-b12c-b1d5, GHSA-rf5r-cr88-cr97 and 6 more.