# CVE-2021-3393: Generation of Error Message Containing Sensitive Information in postgresql

> Attackers with UPDATE but not SELECT permissions can leak column data via crafted queries causing error messages.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2021-3393, BIT-postgresql-2021-3393, CLEANSTART-2026-FG88003, DEBIAN-CVE-2021-3393, ECHO-706e-b12c-b1d5, GHSA-rf5r-cr88-cr97, JLSEC-2026-34, SUSE-SU-2021:0544-1, SUSE-SU-2021:0695-1, UBUNTU-CVE-2021-3393, USN-4735-1, openSUSE-SU-2021:0423-1

## What is CVE-2021-3393?

CVE-2021-3393 is a medium-severity vulnerability in Postgresql Postgresql, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11. A user having UPDATE permission but not SELECT permission to a particular column could craft queries which, under some circumstances, might disclose values from that column in error messages. An attacker could use this flaw to obtain information stored in a column they are allowed to write but not read.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2021-3393?

1 open source package ship an affected version, including postgresql. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `postgresql` | Bitnami | All versions | 11.11.0, 12.6.0, 13.2.0 |
| `postgresql12` | SUSE:Enterprise Storage 6 | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 12.6-8.16.1 |
| `postgresql12` | SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 12.6-8.16.1 |
| `postgresql12` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Manager Proxy 4.0 | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Manager Retail Branch Server 4.0 | All versions | 12.6-3.21.4 |
| `postgresql12` | SUSE:Manager Server 4.0 | All versions | 12.6-3.21.4 |
| `postgresql12` | openSUSE:Leap 15.2 | All versions | 12.6-lp152.3.16.1 |

Products: Postgresql Postgresql, Redhat Enterprise Linux, Redhat Software Collections.

## How do I fix CVE-2021-3393?

Upgrade postgresql to a fixed version for your release line: 11.11.0, 12.6.0 or 13.2.0.

## Is CVE-2021-3393 being exploited?

There is no known exploitation of CVE-2021-3393 in the wild and no public exploit code.

## Other vulnerabilities in Postgresql Postgresql

- [CVE-2013-1902](https://insights.sbomify.com/CVE-2013-1902/): Information disclosure in n/a (critical 10.0)
- [CVE-2013-1903](https://insights.sbomify.com/CVE-2013-1903/): Information disclosure in n/a (critical 10.0)
- [CVE-2007-3279](https://insights.sbomify.com/CVE-2007-3279/): Privilege escalation in n/a (critical 10.0)
- [CVE-2002-1399](https://insights.sbomify.com/CVE-2002-1399/): Integer overflow in n/a (critical 10.0)
- [CVE-2016-3065](https://insights.sbomify.com/CVE-2016-3065/): Information disclosure in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3393 and fix it if it is affected.

What it is: CVE-2021-3393 is a medium-severity vulnerability in Postgresql Postgresql, published on 1 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3393 in the wild and no public exploit code.

Affected packages and fixed versions:
- postgresql (Bitnami): affected all versions; fixed in 11.11.0, 12.6.0, 13.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3393/ (Markdown: https://insights.sbomify.com/CVE-2021-3393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3393
- OSV: https://osv.dev/vulnerability/CVE-2021-3393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3393/
Summaries are generated and may contain mistakes; the official description above is the record.
