# CVE-2021-3396: OpenNMS Horizon RCE via JEXL2 expression

> Attackers can execute arbitrary code via JEXL expressions due to incorrect access control in OpenNMS Meridian and Horizon.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-c3mp-9vx3-2rvv

## What is CVE-2021-3396?

CVE-2021-3396 is a high-severity code injection vulnerability in n/a, published on 17 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenNMS Meridian 2016, 2017, 2018 before 2018.1.25, 2019 before 2019.1.16, and 2020 before 2020.1.5, Horizon 1.2 through 27.0.4, and Newts <1.5.3 has Incorrect Access Control, which allows local and remote code execution using JEXL expressions.

## Which versions are affected by CVE-2021-3396?

8 open source packages ship an affected version, including org.opennms.features:org.opennms.features.measurements, org.opennms:opennms and org.opennms:opennms-provision. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opennms.features:org.opennms.features.measurements` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms.features:org.opennms.features.measurements` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms-provision` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms-provision` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms-util` | Maven | From 16.0.0 | 27.0.4 |
| `org.opennms:opennms-util` | Maven | From 16.0.0 | 27.0.4 |

Products: Opennms Horizon, Opennms Meridian, Opennms Newts.

## How do I fix CVE-2021-3396?

Upgrade org.opennms.features:org.opennms.features.measurements to 27.0.4 or later.

## Is CVE-2021-3396 being exploited?

There is no known exploitation of CVE-2021-3396 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-25931](https://insights.sbomify.com/CVE-2021-25931/): Cross-Site Request Forgery in OpenNMS Horizon (high 8.8)
- [CVE-2023-0872](https://insights.sbomify.com/CVE-2023-0872/): ROLE_REST can be used to escalate to ROLE_ADMIN via /rest/users (high 8.2)
- [CVE-2023-0870](https://insights.sbomify.com/CVE-2023-0870/): Form Can Be Manipulated with Cross-Site Request Forgery (CSRF) (high 8.1)
- [CVE-2020-11886](https://insights.sbomify.com/CVE-2020-11886/): SQL injection in n/a (high 8.1)
- [CVE-2023-40313](https://insights.sbomify.com/CVE-2023-40313/): Disable BeanShell Interpreter Remote Server Mode (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3396 and fix it if it is affected.

What it is: CVE-2021-3396 is a high-severity code injection vulnerability in n/a, published on 17 Feb 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3396 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opennms.features:org.opennms.features.measurements (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms.features:org.opennms.features.measurements (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms-provision (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms-provision (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms-util (Maven): affected from 16.0.0; fixed in 27.0.4
- org.opennms:opennms-util (Maven): affected from 16.0.0; fixed in 27.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3396/ (Markdown: https://insights.sbomify.com/CVE-2021-3396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3396
- OSV: https://osv.dev/vulnerability/CVE-2021-3396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3396/
Summaries are generated and may contain mistakes; the official description above is the record.
