# CVE-2021-34141: Incorrect Comparison in NumPy

> An incomplete string comparison in NumPy allows attackers to trigger slightly incorrect copying, though the vendor deems the behavior harmless.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2025-1760400833, CLSA-2026-1781139192, DEBIAN-CVE-2021-34141, ECHO-4195-024c-0bcd, GHSA-fpfv-jqm9-f5jm, MINI-wq6v-xg86-wg83, PYSEC-2021-855, UBUNTU-CVE-2021-34141

## What is CVE-2021-34141?

CVE-2021-34141 is a medium-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An incomplete string comparison in the numpy.core component in NumPy before 1.22.0 allows attackers to trigger slightly incorrect copying by constructing specific string objects. NOTE: the vendor states that this reported code behavior is "completely harmless."

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2021-34141?

3 open source packages ship an affected version, including numpy. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `numpy` | PyPI | All versions | 1.22 |
| `numpy` | PyPI | All versions | 1.22 |
| `numpy` | PyPI | From 1.9.0 | 1.10.0 |

Products: Numpy Numpy, Oracle Communications Cloud Native Core Policy.

## How do I fix CVE-2021-34141?

Upgrade numpy to a fixed version for your release line: 1.22 or 1.10.0.

## Is CVE-2021-34141 being exploited?

There is no known exploitation of CVE-2021-34141 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Communications Cloud Native Core Policy

- [CVE-2017-12852](https://insights.sbomify.com/CVE-2017-12852/): Numpy missing input validation (high 7.5)
- [CVE-2021-41496](https://insights.sbomify.com/CVE-2021-41496/): Buffer Copy without Checking Size of Input in NumPy (medium 5.5)
- [CVE-2014-1858](https://insights.sbomify.com/CVE-2014-1858/): Arbitrary file write in NumPy (medium 5.5)
- [CVE-2021-33430](https://insights.sbomify.com/CVE-2021-33430/): NumPy Buffer Overflow (Disputed) (medium 5.3)
- [CVE-2021-41495](https://insights.sbomify.com/CVE-2021-41495/): NumPy NULL Pointer Dereference (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-34141 and fix it if it is affected.

What it is: CVE-2021-34141 is a medium-severity vulnerability in Oracle Communications Cloud Native Core Policy, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-34141 in the wild and no public exploit code.

Affected packages and fixed versions:
- numpy (PyPI): affected all versions; fixed in 1.22
- numpy (PyPI): affected all versions; fixed in 1.22
- numpy (PyPI): affected from 1.9.0; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-34141/ (Markdown: https://insights.sbomify.com/CVE-2021-34141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-34141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-34141
- OSV: https://osv.dev/vulnerability/CVE-2021-34141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-34141/
Summaries are generated and may contain mistakes; the official description above is the record.
