{"answers":{"affected":"3 open source packages ship an affected version, including deluge. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-3427 in the wild and no public exploit code.","fix":"Upgrade deluge to 2.1.0 or later.","what":"CVE-2021-3427 is a medium-severity cross-site scripting vulnerability in Deluge-web, published on 26 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-3427 and fix it if it is affected.\n\nWhat it is: CVE-2021-3427 is a medium-severity cross-site scripting vulnerability in Deluge-web, published on 26 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-3427 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- deluge (PyPI): affected all versions; fixed in 2.1.0\n- deluge (PyPI): affected all versions; fixed in 2.1.0\n- deluge (PyPI): affected all versions; fixed in 2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3427/ (Markdown: https://insights.sbomify.com/CVE-2021-3427/index.md)","id":"CVE-2021-3427","markdown":"https://insights.sbomify.com/CVE-2021-3427/index.md","name":"CVE-2021-3427","record":{"aliases":["DEBIAN-CVE-2021-3427","GHSA-5c8p-qhch-qhx6","PYSEC-2022-256","UBUNTU-CVE-2021-3427","openSUSE-SU-2024:12322-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Deluge Web-UI","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in the victim's browser by providing a malicious torrent file to the Deluge Web-UI.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"deluge","vendor":"deluge-torrent"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.","ecosystems":["PyPI","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Deluge Web-UI vulnerable to XSS through a crafted torrent file","id":"CVE-2021-3427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":4,"n_references":3,"next":{"headline":"Integer overflow in kernel","id":"CVE-2021-3428"},"packages":[{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"deluge","purl":null,"source":"GHSA-5c8p-qhch-qhx6"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"deluge","purl":"pkg:pypi/deluge","source":"GHSA-5c8p-qhch-qhx6"},{"ecosystem":"PyPI","fixed":["2.1.0"],"introduced":["0"],"last_affected":[],"package":"deluge","purl":"pkg:pypi/deluge","source":"PYSEC-2022-256"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.1.1-3.1"],"introduced":["0"],"last_affected":[],"package":"deluge","purl":"pkg:rpm/opensuse/deluge\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12322-1"}],"prev":{"headline":"Information disclosure in python","id":"CVE-2021-3426"},"products":["Deluge-web"],"published":"2022-08-26","related":[{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2017-9031","kev_date_added":null,"published":"2017-05-17"},{"cvss_score":6.9,"headline":"Deluge 1.3.15 Denial of Service via Webseeds Field","id":"CVE-2019-25585","kev_date_added":null,"published":"2026-03-22"},{"cvss_score":6.9,"headline":"Deluge 1.3.15 Denial of Service via URL Field","id":"CVE-2019-25586","kev_date_added":null,"published":"2026-03-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript in the victim's browser by providing a malicious torrent file to the Deluge Web-UI.","url":"https://insights.sbomify.com/CVE-2021-3427/"}