# CVE-2021-3427: Deluge Web-UI vulnerable to XSS through a crafted torrent file

> Attackers can execute arbitrary JavaScript in the victim's browser by providing a malicious torrent file to the Deluge Web-UI.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-3427, GHSA-5c8p-qhch-qhx6, PYSEC-2022-256, UBUNTU-CVE-2021-3427, openSUSE-SU-2024:12322-1

## What is CVE-2021-3427?

CVE-2021-3427 is a medium-severity cross-site scripting vulnerability in Deluge-web, published on 26 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Deluge Web-UI is vulnerable to XSS through a crafted torrent file. The the data from torrent files is not properly sanitised as it's interpreted directly as HTML. Someone who supplies the user with a malicious torrent file can execute arbitrary Javascript code in the context of the user's browser session.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3427?

3 open source packages ship an affected version, including deluge. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deluge` | PyPI | All versions | 2.1.0 |
| `deluge` | PyPI | All versions | 2.1.0 |
| `deluge` | PyPI | All versions | 2.1.0 |
| `deluge` | openSUSE:Tumbleweed | All versions | 2.1.1-3.1 |

Products: Deluge-Torrent Deluge.

## How do I fix CVE-2021-3427?

Upgrade deluge to 2.1.0 or later.

## Is CVE-2021-3427 being exploited?

There is no known exploitation of CVE-2021-3427 in the wild and no public exploit code.

## Other vulnerabilities in Deluge-web

- [CVE-2017-9031](https://insights.sbomify.com/CVE-2017-9031/): Path traversal in n/a (critical 9.8)
- [CVE-2019-25585](https://insights.sbomify.com/CVE-2019-25585/): Deluge 1.3.15 Denial of Service via Webseeds Field (medium 6.9)
- [CVE-2019-25586](https://insights.sbomify.com/CVE-2019-25586/): Deluge 1.3.15 Denial of Service via URL Field (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3427 and fix it if it is affected.

What it is: CVE-2021-3427 is a medium-severity cross-site scripting vulnerability in Deluge-web, published on 26 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3427 in the wild and no public exploit code.

Affected packages and fixed versions:
- deluge (PyPI): affected all versions; fixed in 2.1.0
- deluge (PyPI): affected all versions; fixed in 2.1.0
- deluge (PyPI): affected all versions; fixed in 2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3427/ (Markdown: https://insights.sbomify.com/CVE-2021-3427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3427
- OSV: https://osv.dev/vulnerability/CVE-2021-3427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3427/
Summaries are generated and may contain mistakes; the official description above is the record.
