# CVE-2021-34337: Mailman Core vulnerable to timing attacks

> An attacker can use timing attacks to discover the REST API password, enabling unauthorized API access if the service is exposed beyond localhost.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2023
- **Updated:** 6 Feb 2025
- **Also known as:** DEBIAN-CVE-2021-34337, GHSA-2jg5-xgvv-4wq7, OESA-2022-2005, PYSEC-2023-22, UBUNTU-CVE-2021-34337, openSUSE-SU-2024:11644-1, openSUSE-SU-2024:11760-1

## What is CVE-2021-34337?

CVE-2021-34337 is a medium-severity vulnerability in n/a, published on 15 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in Mailman Core before 3.3.5. An attacker with access to the REST API could use timing attacks to determine the value of the configured REST API password and then make arbitrary REST API calls. The REST API is bound to localhost by default, limiting the ability for attackers to exploit this, but can optionally be made to listen on other interfaces.

Weakness: CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2021-34337?

3 open source packages ship an affected version, including mailman. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailman` | PyPI | All versions | 3.3.5 |
| `mailman` | PyPI | All versions | 3.3.5 |
| `mailman` | PyPI | All versions | 3.3.5 |
| `mailman3` | openSUSE:Tumbleweed | All versions | 3.3.5-2.1 |
| `python3-mailman` | openSUSE:Tumbleweed | All versions | 3.3.5-1.1 |

Products: Gnu Mailman.

## How do I fix CVE-2021-34337?

Upgrade mailman to 3.3.5 or later.

## Is CVE-2021-34337 being exploited?

There is no known exploitation of CVE-2021-34337 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-6893](https://insights.sbomify.com/CVE-2016-6893/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2016-7123](https://insights.sbomify.com/CVE-2016-7123/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2005-4153](https://insights.sbomify.com/CVE-2005-4153/): Denial of service in n/a (high 7.8)
- [CVE-2006-2191](https://insights.sbomify.com/CVE-2006-2191/): Other in n/a (high 7.5)
- [CVE-2004-1143](https://insights.sbomify.com/CVE-2004-1143/): Weak cryptography in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-34337 and fix it if it is affected.

What it is: CVE-2021-34337 is a medium-severity vulnerability in n/a, published on 15 Apr 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-34337 in the wild and no public exploit code.

Affected packages and fixed versions:
- mailman (PyPI): affected all versions; fixed in 3.3.5
- mailman (PyPI): affected all versions; fixed in 3.3.5
- mailman (PyPI): affected all versions; fixed in 3.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-34337/ (Markdown: https://insights.sbomify.com/CVE-2021-34337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-34337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-34337
- OSV: https://osv.dev/vulnerability/CVE-2021-34337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-34337/
Summaries are generated and may contain mistakes; the official description above is the record.
