# CVE-2021-34428: SessionListener can prevent a session from being invalidated breaking logout

> Attackers can maintain unauthorized access on shared computers if session invalidation fails due to exceptions in clustered Jetty deployments.

- **Severity:** Low 2.9 (`CVSS:3.1/AV:P/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-IJ78977, DEBIAN-CVE-2021-34428, GHSA-m6cp-vxjx-65j6, OESA-2021-1263, UBUNTU-CVE-2021-34428

## What is CVE-2021-34428?

CVE-2021-34428 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 22 Jun 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

For Eclipse Jetty versions <= 9.4.40, <= 10.0.2, <= 11.0.2, if an exception is thrown from the SessionListener#sessionDestroyed() method, then the session ID is not invalidated in the session ID manager. On deployments with clustered sessions and multiple contexts this can result in a session not being invalidated. This can result in an application used on a shared computer being left logged in.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2021-34428?

6 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 16 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.4.41 |
| `org.eclipse.jetty:jetty-server` | Maven | All versions | 9.4.41 |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 | 10.0.3 |
| `org.eclipse.jetty:jetty-server` | Maven | From 10.0.0 | 10.0.3 |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 | 11.0.3 |
| `org.eclipse.jetty:jetty-server` | Maven | From 11.0.0 | 11.0.3 |

Products: Debian Debian Linux, Eclipse Jetty, Netapp Active Iq Unified Manager, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Web Services, Netapp Element Plug-in for Vcenter Server, Netapp Santricity Cloud Connector, Netapp Snap Creator Framework, Netapp Snapmanager, Oracle Autovue for Agile Product Lifecycle Management, Oracle Communications Element Manager, Oracle Communications Services Gatekeeper, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Rest Data Services, Oracle Siebel Core - Automation.

## How do I fix CVE-2021-34428?

Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 9.4.41, 10.0.3 or 11.0.3.

## Is CVE-2021-34428 being exploited?

There is no known exploitation of CVE-2021-34428 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Trinadh465/jetty_9.4.31_CVE-2021-34428 (github_poc): https://github.com/Trinadh465/jetty_9.4.31_CVE-2021-34428

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-34428 and fix it if it is affected.

What it is: CVE-2021-34428 is a low-severity authentication bypass vulnerability in Debian Debian Linux, published on 22 Jun 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-34428 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.4.41
- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 9.4.41
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0; fixed in 10.0.3
- org.eclipse.jetty:jetty-server (Maven): affected from 10.0.0; fixed in 10.0.3
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0; fixed in 11.0.3
- org.eclipse.jetty:jetty-server (Maven): affected from 11.0.0; fixed in 11.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-34428/ (Markdown: https://insights.sbomify.com/CVE-2021-34428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-34428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-34428
- OSV: https://osv.dev/vulnerability/CVE-2021-34428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-34428/
Summaries are generated and may contain mistakes; the official description above is the record.
