# CVE-2021-34435: Remote code execution in Eclipse Theia

> Attackers can achieve remote code execution by tricking users into previewing malicious HTML files in the Eclipse Theia mini-browser extension.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-v9w2-v7j9-rjpr

## What is CVE-2021-34435?

CVE-2021-34435 is a high-severity code injection vulnerability in Eclipse Theia, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Eclipse Theia 0.3.9 to 1.8.1, the "mini-browser" extension allows a user to preview HTML files in an iframe inside the IDE. But with the way it is made it is possible for a previewed HTML file to trigger an RCE. This exploit only happens if a user previews a malicious file..

Weakness: CWE-346 (Origin Validation Error), CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2021-34435?

2 open source packages ship an affected version, including @theia/mini-browser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@theia/mini-browser` | npm | From 0.3.9 | 1.9.0 |
| `@theia/mini-browser` | npm | From 0.3.9 | 1.9.0 |

Products: Eclipse Theia.

## How do I fix CVE-2021-34435?

Upgrade @theia/mini-browser to 1.9.0 or later.

## Is CVE-2021-34435 being exploited?

There is no known exploitation of CVE-2021-34435 in the wild and no public exploit code.

## Other vulnerabilities in Eclipse Theia

- [CVE-2021-34436](https://insights.sbomify.com/CVE-2021-34436/): XML external entity in Eclipse Theia (critical 9.8)
- [CVE-2020-27224](https://insights.sbomify.com/CVE-2020-27224/): Cross-site Scripting (XSS) in Eclipse Theia (critical 9.6)
- [CVE-2026-60009](https://insights.sbomify.com/CVE-2026-60009/): File upload in Eclipse Theia (high 8.8)
- [CVE-2026-44688](https://insights.sbomify.com/CVE-2026-44688/): [Eclipse Theia] Indirect Prompt Injection via Adversarial Workspace File and Directory Names in AI Chat (high 8.4)
- [CVE-2026-44691](https://insights.sbomify.com/CVE-2026-44691/): [Eclipse Theia] Arbitrary Command Execution via Untrusted Workspace Task Definitions (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-34435 and fix it if it is affected.

What it is: CVE-2021-34435 is a high-severity code injection vulnerability in Eclipse Theia, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-34435 in the wild and no public exploit code.

Affected packages and fixed versions:
- @theia/mini-browser (npm): affected from 0.3.9; fixed in 1.9.0
- @theia/mini-browser (npm): affected from 0.3.9; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-34435/ (Markdown: https://insights.sbomify.com/CVE-2021-34435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-34435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-34435
- OSV: https://osv.dev/vulnerability/CVE-2021-34435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-34435/
Summaries are generated and may contain mistakes; the official description above is the record.
