# CVE-2021-3447: Information disclosure in ansible

> Ansible modules log sensitive credentials in plain text, allowing attackers with log access to steal secrets and compromise data confidentiality.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-3447, GHSA-29hx-hv84-8wcq, PYSEC-2021-107, RHSA-2021:1342, RHSA-2021:1343, RHSA-2021:2866, UBUNTU-CVE-2021-3447

## What is CVE-2021-3447?

CVE-2021-3447 is a medium-severity vulnerability in Fedoraproject Fedora, published on 1 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A flaw was found in several ansible modules, where parameters containing credentials, such as secrets, were being logged in plain-text on managed nodes, as well as being made visible on the controller node when run in verbose mode. These parameters were not protected by the no_log feature. An attacker can take advantage of this information to steal those credentials, provided when they have access to the log files containing them. The highest threat from this vulnerability is to data confidentiality. This flaw affects Red Hat Ansible Automation Platform in versions before 1.2.2 and Ansible Tower in versions before 3.8.2.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2021-3447?

1 open source package ship an affected version, including ansible. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 1.2.2 |
| `ansible` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.20-1.el7ae |
| `ansible-test` | Red Hat:ansible_engine:2.9::el7 | All versions | 0:2.9.20-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.20-1.el8ae |
| `ansible-test` | Red Hat:ansible_engine:2.9::el8 | All versions | 0:2.9.20-1.el8ae |
| `ansible` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.20-1.el7ae |
| `ansible-test` | Red Hat:ansible_engine:2::el7 | All versions | 0:2.9.20-1.el7ae |
| `ansible` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.20-1.el8ae |
| `ansible-test` | Red Hat:ansible_engine:2::el8 | All versions | 0:2.9.20-1.el8ae |
| `ansible` | Red Hat:rhev_hypervisor:4.4::el8 | All versions | 0:2.9.21-1.el8ae |
| `ansible` | Red Hat:rhev_manager:4.4:el8 | All versions | 0:2.9.21-1.el8ae |

Products: Fedoraproject Fedora, Redhat Ansible, Redhat Ansible Tower.

## How do I fix CVE-2021-3447?

Upgrade ansible to 1.2.2 or later.

## Is CVE-2021-3447 being exploited?

There is no known exploitation of CVE-2021-3447 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3447 and fix it if it is affected.

What it is: CVE-2021-3447 is a medium-severity vulnerability in Fedoraproject Fedora, published on 1 Apr 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3447 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3447/ (Markdown: https://insights.sbomify.com/CVE-2021-3447/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3447
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3447
- OSV: https://osv.dev/vulnerability/CVE-2021-3447

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3447/
Summaries are generated and may contain mistakes; the official description above is the record.
