# CVE-2021-3449: NULL pointer deref in signature_algorithms processing

> A remote attacker can crash an OpenSSL TLS server by sending a crafted renegotiation ClientHello message, causing a denial of service.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2021
- **Updated:** 8 Oct 2026
- **Also known as:** ALPINE-CVE-2021-3449, BIT-node-2021-3449, BIT-node-min-2021-3449, CLEANSTART-2026-RT76618, DEBIAN-CVE-2021-3449, DSA-4875-1, GHSA-83mx-573x-5rw9, JLSEC-2026-223, OESA-2021-1147, RHSA-2021:1063, RHSA-2021:1131, RUSTSEC-2021-0055, SUSE-SU-2021:0954-1, SUSE-SU-2021:0955-1, SUSE-SU-2021:0955-2, UBUNTU-CVE-2021-3449, USN-4891-1, openSUSE-SU-2021:0476-1

## What is CVE-2021-3449?

CVE-2021-3449 is a medium-severity vulnerability in Debian Debian Linux, published on 25 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client. If a TLSv1.2 renegotiation ClientHello omits the signature_algorithms extension (where it was present in the initial ClientHello), but includes a signature_algorithms_cert extension then a NULL pointer dereference will result, leading to a crash and a denial of service attack. A server is only vulnerable if it has TLSv1.2 and renegotiation enabled (which is the default configuration). OpenSSL TLS clients are not impacted by this issue. All OpenSSL 1.1.1 versions are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1-1.1.1j).

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-3449?

5 open source packages ship an affected version, including openssl-src, node and node-min. It affects 106 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | All versions | 111.15.0 |
| `openssl-src` | crates.io | All versions | 111.15.0 |
| `openssl-src` | crates.io | From 0.0.0-0 | 111.15.0 |
| `node` | Bitnami | From 10.0.0 | 10.12.1, 10.24.1, 12.12.1, 12.22.1, 14.14.1, 14.16.1, 15.14.0 |
| `node-min` | Bitnami | From 10.0.0 | 10.12.1, 10.24.1, 12.12.1, 12.22.1, 14.14.1, 14.16.1, 15.14.0 |
| `openssl` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-debuginfo` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-debugsource` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-devel` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-libs` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-libs-debuginfo` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl-perl` | Red Hat:rhel_eus:8.1::baseos | All versions | 1:1.1.1c-5.el8_1 |
| `openssl` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-debuginfo` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-debugsource` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-devel` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-libs` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-libs-debuginfo` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-perl` | Red Hat:rhel_eus:8.2::baseos | All versions | 1:1.1.1c-18.el8_2 |
| `openssl-1_1` | SUSE:Linux Enterprise Micro 5.0 | All versions | 1.1.1d-11.20.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.1.1d-11.20.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Module for Certifications 15 SP3 | All versions | 1.1.1d-11.20.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:OpenStack Cloud 9 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.1.1d-2.33.1 |
| `openssl-1_1` | openSUSE:Leap 15.2 | All versions | 1.1.1d-lp152.7.15.1 |

Products: Checkpoint Multi-Domain Management Firmware, Checkpoint Quantum Security Gateway Firmware, Checkpoint Quantum Security Management Firmware, Debian Debian Linux, Fedoraproject Fedora, Freebsd Freebsd, Mcafee Web Gateway, Mcafee Web Gateway Cloud Service, Netapp Active Iq Unified Manager, Netapp Cloud Volumes Ontap Mediator, Netapp E-Series Performance Analyzer, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Ontap Select Deploy Administration Utility, Netapp Santricity Smi-S Provider, Netapp Snapcenter, Netapp Storagegrid, Nodejs Node.js, Openssl Openssl, Oracle Communications Communications Policy Management and 86 more.

## How do I fix CVE-2021-3449?

Upgrade openssl-src to 111.15.0 or later.

## Is CVE-2021-3449 being exploited?

There is no known exploitation of CVE-2021-3449 in the wild and no public exploit code.

Public exploit code:

- CVE-2021-3449 OpenSSL denial-of-service exploit 👨🏻‍💻 (github_poc): https://github.com/riptl/cve-2021-3449

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3449 and fix it if it is affected.

What it is: CVE-2021-3449 is a medium-severity vulnerability in Debian Debian Linux, published on 25 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3449 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected all versions; fixed in 111.15.0
- openssl-src (crates.io): affected all versions; fixed in 111.15.0
- openssl-src (crates.io): affected from 0.0.0-0; fixed in 111.15.0
- node (Bitnami): affected from 10.0.0; fixed in 10.12.1, 10.24.1, 12.12.1, 12.22.1, 14.14.1, 14.16.1, 15.14.0
- node-min (Bitnami): affected from 10.0.0; fixed in 10.12.1, 10.24.1, 12.12.1, 12.22.1, 14.14.1, 14.16.1, 15.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3449/ (Markdown: https://insights.sbomify.com/CVE-2021-3449/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3449
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3449
- OSV: https://osv.dev/vulnerability/CVE-2021-3449

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3449/
Summaries are generated and may contain mistakes; the official description above is the record.
