# CVE-2021-3450: CA certificate check bypass with X509_V_FLAG_X509_STRICT

> Attackers can bypass CA certificate checks in OpenSSL when X509_V_FLAG_X509_STRICT is enabled without a purpose, allowing invalid certificates to be accepted.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2021
- **Updated:** 8 Oct 2026
- **Also known as:** ALPINE-CVE-2021-3450, BIT-node-2021-3450, BIT-node-min-2021-3450, CLEANSTART-2026-JY20850, DEBIAN-CVE-2021-3450, GHSA-8hfj-xrj2-pm22, RUSTSEC-2021-0056

## What is CVE-2021-3450?

CVE-2021-3450 is a high-severity vulnerability in Fedoraproject Fedora, published on 25 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2021-3450?

5 open source packages ship an affected version, including openssl-src, node and node-min. It affects 33 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 111.11.0 | 111.15.0 |
| `openssl-src` | crates.io | From 111.11.0 | 111.15.0 |
| `openssl-src` | crates.io | From 111.11.0 | 111.15.0 |
| `node` | Bitnami | From 10.0.0 | 10.24.1, 12.22.1, 14.16.1, 15.14.0 |
| `node-min` | Bitnami | From 10.0.0 | 10.24.1, 12.22.1, 14.16.1, 15.14.0 |

Products: Fedoraproject Fedora, Freebsd Freebsd, Mcafee Web Gateway, Mcafee Web Gateway Cloud Service, Netapp Cloud Volumes Ontap Mediator, Netapp Oncommand Workflow Automation, Netapp Ontap Select Deploy Administration Utility, Netapp Santricity Smi-S Provider Firmware, Netapp Storagegrid, Netapp Storagegrid Firmware, Nodejs Node.js, Openssl Openssl, Oracle Commerce Guided Search, Oracle Enterprise Manager for Storage Management, Oracle Graalvm, Oracle Jd Edwards Enterpriseone Tools, Oracle Jd Edwards World Security, Oracle Mysql Connectors, Oracle Mysql Enterprise Monitor, Oracle Mysql Server and 13 more.

## How do I fix CVE-2021-3450?

Upgrade openssl-src to 111.15.0 or later.

## Is CVE-2021-3450 being exploited?

There is no known exploitation of CVE-2021-3450 in the wild and no public exploit code.

Public exploit code:

- Mutation testing on X.509 Certificate Validation IN OpenSSL v.1.1.1h, based on CVE-2021-3450. (github_poc): https://github.com/dedellix/MUT-BC-SS-01

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3450 and fix it if it is affected.

What it is: CVE-2021-3450 is a high-severity vulnerability in Fedoraproject Fedora, published on 25 Mar 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3450 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 111.11.0; fixed in 111.15.0
- openssl-src (crates.io): affected from 111.11.0; fixed in 111.15.0
- openssl-src (crates.io): affected from 111.11.0; fixed in 111.15.0
- node (Bitnami): affected from 10.0.0; fixed in 10.24.1, 12.22.1, 14.16.1, 15.14.0
- node-min (Bitnami): affected from 10.0.0; fixed in 10.24.1, 12.22.1, 14.16.1, 15.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3450/ (Markdown: https://insights.sbomify.com/CVE-2021-3450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3450
- OSV: https://osv.dev/vulnerability/CVE-2021-3450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3450/
Summaries are generated and may contain mistakes; the official description above is the record.
