# CVE-2021-34551: Remote Code Execution vulnerability in PHPMailer 6.4.1 running on Windows

> Remote code execution is possible in PHPMailer on Windows if the language path is controlled by an attacker and uses a UNC pathname.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-phpmailer-2021-34551, GHSA-7q44-r25x-wm4q

## What is CVE-2021-34551?

CVE-2021-34551 is a high-severity vulnerability in Fedoraproject Fedora, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHPMailer before 6.5.0 on Windows allows remote code execution if lang_path is untrusted data and has a UNC pathname.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2021-34551?

3 open source packages ship an affected version, including phpmailer/phpmailer and phpmailer. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 6.5.0 |
| `phpmailer/phpmailer` | Packagist | All versions | 6.5.0 |
| `phpmailer` | Bitnami | All versions | 6.5.0 |

Products: Fedoraproject Fedora, Phpmailer Project Phpmailer.

## How do I fix CVE-2021-34551?

Upgrade phpmailer/phpmailer to 6.5.0 or later.

## Is CVE-2021-34551 being exploited?

There is no known exploitation of CVE-2021-34551 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-34551 and fix it if it is affected.

What it is: CVE-2021-34551 is a high-severity vulnerability in Fedoraproject Fedora, published on 16 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-34551 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0
- phpmailer (Bitnami): affected all versions; fixed in 6.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-34551/ (Markdown: https://insights.sbomify.com/CVE-2021-34551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-34551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-34551
- OSV: https://osv.dev/vulnerability/CVE-2021-34551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-34551/
Summaries are generated and may contain mistakes; the official description above is the record.
