{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-34640 exists.","fix":"No fix has been published for CVE-2021-34640 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-34640 is a medium-severity cross-site scripting vulnerability in Securimage-WP-Fixed, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-34640 and fix it if it is affected.\n\nWhat it is: CVE-2021-34640 is a medium-severity cross-site scripting vulnerability in Securimage-WP-Fixed, published on 11 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-34640 exists.\n\nAffected product: Securimage-WP-Fixed. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-34640/ (Markdown: https://insights.sbomify.com/CVE-2021-34640/index.md)","id":"CVE-2021-34640","markdown":"https://insights.sbomify.com/CVE-2021-34640/index.md","name":"CVE-2021-34640","record":{"aliases":["GHSA-ww58-2pvw-x3p4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Attackers can inject arbitrary web scripts via reflected XSS in the Securimage-WP-Fixed WordPress plugin, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"securimage-wp-fixed","vendor":"securimage-wp-fixed_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Securimage-WP-Fixed WordPress plugin is vulnerable to Reflected Cross-Site Scripting due to the use of $_SERVER['PHP_SELF'] in the ~/securimage-wp.php file which allows attackers to inject arbitrary web scripts, in versions up to and including 3.5.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-34640.yaml","stars":null,"title":"WordPress Securimage-WP-Fixed \u003c=3.5.4 - Cross-Site Scripting"}],"tier":"weaponised"},"has_fix":null,"headline":"Securimage-WP-Fixed \u003c= 3.5.4 Reflected Cross-Site Scripting","id":"CVE-2021-34640","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2021"},"n_packages":0,"n_references":2,"next":{"headline":"SEOPress \u003c= 5.0.0 – 5.0.3 Authenticated Stored Cross-Site Scripting","id":"CVE-2021-34641"},"packages":[],"prev":{"headline":"WordPress Download Manager \u003c= 3.1.24 Authenticated Arbitrary File Upload","id":"CVE-2021-34639"},"products":["Securimage-WP-Fixed"],"published":"2021-08-11","related":[{"cvss_score":4.3,"headline":"WordPress Securimage-WP Plugin \u003c= 3.6.16 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2023-35044","kev_date_added":null,"published":"2023-07-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-23","vendors":["Securimage-WP-Fixed"]},"summary":"Attackers can inject arbitrary web scripts via reflected XSS in the Securimage-WP-Fixed WordPress plugin, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2021-34640/"}