CVE-2021-34797 Apache Geode project log file redaction of sensitive information vulnerability
Attackers can read sensitive passwords and security properties from log files due to improper redaction in Apache Geode.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-34797?
CVE-2021-34797 is a high-severity vulnerability in Apache Geode, published on 4 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Geode versions up to 1.12.4 and 1.13.4 are vulnerable to a log file redaction of sensitive information flaw when using values that begin with characters other than letters or numbers for passwords and security properties with the prefix "sysprop-", "javax.net.ssl", or "security-". This issue is fixed by overhauling the log file redaction in Apache Geode versions 1.12.5, 1.13.5, and 1.14.0.
Weakness: CWE-532
Which versions are affected by CVE-2021-34797?
4 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.geode:geode-core Maven | All versions | 1.12.5 |
org.apache.geode:geode-core Maven | All versions | 1.12.5 |
org.apache.geode:geode-core Maven | From 1.13.0 | 1.13.5 |
org.apache.geode:geode-core Maven | From 1.13.0 | 1.13.5 |
Products include Apache Geode.
How do I fix CVE-2021-34797?
Upgrade org.apache.geode:geode-core to a fixed version for your release line: 1.12.5 or 1.13.5.
Is CVE-2021-34797 being exploited?
There is no known exploitation of CVE-2021-34797 in the wild and no public exploit code.
Other vulnerabilities in Apache Geode
- CVE-2020-1938 Apache Tomcat Improper Privilege Management
- CVE-2019-15752 Docker Desktop Community Edition Privilege Escalation
- CVE-2022-37021 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.
- CVE-2014-0048 Supply chain in docker.io
- CVE-2017-15692 Apache Geode unsafe deserialization in TcpServer
Sources
Also known as GHSA-mw25-f5r2-hpc6.