CVE-2021-3495 Access control flaw in Kiali

High 8.8 Published Updated

An attacker with basic cluster access can deploy arbitrary images to gain privileged service account tokens, compromising confidentiality, integrity, and availability.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-3495?

CVE-2021-3495 is a high-severity vulnerability in kiali/kiali-operator, published on 1 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An incorrect access control flaw was found in the kiali-operator in versions before 1.33.0 and before 1.24.7. This flaw allows an attacker with a basic level of access to the cluster (to deploy a kiali operand) to use this vulnerability and deploy a given image to anywhere in the cluster, potentially gaining access to privileged service account tokens. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-281

Which versions are affected by CVE-2021-3495?

3 open source packages ship an affected version, including github.com/kiali/kiali. It affects 2 products.

PackageAffectedFixed in
github.com/kiali/kiali GoAll versions1.33.0
github.com/kiali/kiali GoAll versions1.33.0
github.com/kiali/kiali GoAll versions1.33.0

Products include Netlify Kiali-Operator, Redhat Openshift Service Mesh.

How do I fix CVE-2021-3495?

Upgrade github.com/kiali/kiali to 1.33.0 or later.

Is CVE-2021-3495 being exploited?

There is no known exploitation of CVE-2021-3495 in the wild and no public exploit code.

Sources

Also known as GHSA-mv55-23xp-3wp8, GO-2022-0645.

Is CVE-2021-3495 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free