# CVE-2021-3495: Access control flaw in Kiali

> An attacker with basic cluster access can deploy arbitrary images to gain privileged service account tokens, compromising confidentiality, integrity, and availability.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-mv55-23xp-3wp8, GO-2022-0645

## What is CVE-2021-3495?

CVE-2021-3495 is a high-severity vulnerability in kiali/kiali-operator, published on 1 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An incorrect access control flaw was found in the kiali-operator in versions before 1.33.0 and before 1.24.7. This flaw allows an attacker with a basic level of access to the cluster (to deploy a kiali operand) to use this vulnerability and deploy a given image to anywhere in the cluster, potentially gaining access to privileged service account tokens. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2021-3495?

3 open source packages ship an affected version, including github.com/kiali/kiali. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kiali/kiali` | Go | All versions | 1.33.0 |
| `github.com/kiali/kiali` | Go | All versions | 1.33.0 |
| `github.com/kiali/kiali` | Go | All versions | 1.33.0 |

Products: Netlify Kiali-Operator, Redhat Openshift Service Mesh.

## How do I fix CVE-2021-3495?

Upgrade github.com/kiali/kiali to 1.33.0 or later.

## Is CVE-2021-3495 being exploited?

There is no known exploitation of CVE-2021-3495 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3495 and fix it if it is affected.

What it is: CVE-2021-3495 is a high-severity vulnerability in kiali/kiali-operator, published on 1 Jun 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3495 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kiali/kiali (Go): affected all versions; fixed in 1.33.0
- github.com/kiali/kiali (Go): affected all versions; fixed in 1.33.0
- github.com/kiali/kiali (Go): affected all versions; fixed in 1.33.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3495/ (Markdown: https://insights.sbomify.com/CVE-2021-3495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3495
- OSV: https://osv.dev/vulnerability/CVE-2021-3495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3495/
Summaries are generated and may contain mistakes; the official description above is the record.
