CVE-2021-35065 glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service

High 7.5 Published Updated

Attackers can cause denial of service in applications using the glob-parent library via ReDoS attacks on enclosure regular expressions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2021-35065?

CVE-2021-35065 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The glob-parent package before 6.0.1 for Node.js allows ReDoS (regular expression denial of service) attacks against the enclosure regular expression.

Weakness: CWE-1333

Which versions are affected by CVE-2021-35065?

3 open source packages ship an affected version, including glob-parent and gulp. It affects 1 product.

PackageAffectedFixed in
glob-parent npmFrom 6.0.06.0.1
glob-parent npmFrom 6.0.06.0.1
gulp BitnamiFrom 6.0.06.0.1

Products include Gulpjs Glob-Parent.

How do I fix CVE-2021-35065?

Upgrade glob-parent to 6.0.1 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-35065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-35065 exists.

Sources

Also known as BIT-gulp-2021-35065, DEBIAN-CVE-2021-35065, GHSA-cj88-88mr-972w, UBUNTU-CVE-2021-35065.

Is CVE-2021-35065 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free