{"answers":{"affected":"3 open source packages ship an affected version, including glob-parent and gulp. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-35065 exists.","fix":"Upgrade glob-parent to 6.0.1 or later.","what":"CVE-2021-35065 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-35065 and fix it if it is affected.\n\nWhat it is: CVE-2021-35065 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-35065 exists.\n\nAffected packages and fixed versions:\n- glob-parent (npm): affected from 6.0.0; fixed in 6.0.1\n- glob-parent (npm): affected from 6.0.0; fixed in 6.0.1\n- gulp (Bitnami): affected from 6.0.0; fixed in 6.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-35065/ (Markdown: https://insights.sbomify.com/CVE-2021-35065/index.md)","id":"CVE-2021-35065","markdown":"https://insights.sbomify.com/CVE-2021-35065/index.md","name":"CVE-2021-35065","record":{"aliases":["BIT-gulp-2021-35065","DEBIAN-CVE-2021-35065","GHSA-cj88-88mr-972w","UBUNTU-CVE-2021-35065"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js glob-parent library","requires_auth":"none","summary":"Attackers can cause denial of service in applications using the glob-parent library via ReDoS attacks on enclosure regular expressions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"glob-parent","vendor":"gulpjs"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The glob-parent package before 6.0.1 for Node.js allows ReDoS (regular expression denial of service) attacks against the enclosure regular expression.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service","id":"CVE-2021-35065","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"XML external entity in n/a","id":"CVE-2021-35066"},"packages":[{"ecosystem":"Bitnami","fixed":["6.0.1"],"introduced":["6.0.0"],"last_affected":[],"package":"gulp","purl":"pkg:bitnami/gulp","source":"BIT-gulp-2021-35065"},{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["6.0.0"],"last_affected":[],"package":"glob-parent","purl":null,"source":"GHSA-cj88-88mr-972w"},{"ecosystem":"npm","fixed":["6.0.1"],"introduced":["6.0.0"],"last_affected":[],"package":"glob-parent","purl":"pkg:npm/glob-parent","source":"GHSA-cj88-88mr-972w"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2021-35064"},"products":["n/a"],"published":"2022-12-26","related":[{"cvss_score":5.3,"headline":"Regular Expression Denial of Service (ReDoS)","id":"CVE-2020-28469","kev_date_added":null,"published":"2021-06-03"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["n/a"]},"summary":"Attackers can cause denial of service in applications using the glob-parent library via ReDoS attacks on enclosure regular expressions.","url":"https://insights.sbomify.com/CVE-2021-35065/"}