# CVE-2021-35065: glob-parent 6.0.0 vulnerable to Regular Expression Denial of Service

> Attackers can cause denial of service in applications using the glob-parent library via ReDoS attacks on enclosure regular expressions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** BIT-gulp-2021-35065, DEBIAN-CVE-2021-35065, GHSA-cj88-88mr-972w, UBUNTU-CVE-2021-35065

## What is CVE-2021-35065?

CVE-2021-35065 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The glob-parent package before 6.0.1 for Node.js allows ReDoS (regular expression denial of service) attacks against the enclosure regular expression.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-35065?

3 open source packages ship an affected version, including glob-parent and gulp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glob-parent` | npm | From 6.0.0 | 6.0.1 |
| `glob-parent` | npm | From 6.0.0 | 6.0.1 |
| `gulp` | Bitnami | From 6.0.0 | 6.0.1 |

Products: Gulpjs Glob-Parent.

## How do I fix CVE-2021-35065?

Upgrade glob-parent to 6.0.1 or later.

## Is CVE-2021-35065 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-35065 exists.

## Other vulnerabilities in n/a

- [CVE-2020-28469](https://insights.sbomify.com/CVE-2020-28469/): Regular Expression Denial of Service (ReDoS) (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35065 and fix it if it is affected.

What it is: CVE-2021-35065 is a high-severity denial of service vulnerability in n/a, published on 26 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-35065 exists.

Affected packages and fixed versions:
- glob-parent (npm): affected from 6.0.0; fixed in 6.0.1
- glob-parent (npm): affected from 6.0.0; fixed in 6.0.1
- gulp (Bitnami): affected from 6.0.0; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35065/ (Markdown: https://insights.sbomify.com/CVE-2021-35065/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35065
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35065
- OSV: https://osv.dev/vulnerability/CVE-2021-35065

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35065/
Summaries are generated and may contain mistakes; the official description above is the record.
