# CVE-2021-3518: Nokogiri Implements libxml2 version vulnerable to use-after-free

> An attacker can trigger a use-after-free in libxml2 via a crafted file, potentially leading to code execution or denial of service.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 May 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2021-3518, DEBIAN-CVE-2021-3518, ECHO-cbc1-7e66-bf2c, GHSA-v4f8-2847-rwm7, JLSEC-2025-71, UBUNTU-CVE-2021-3518

## What is CVE-2021-3518?

CVE-2021-3518 is a high-severity use after free vulnerability in Debian Debian Linux, published on 18 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

There's a flaw in libxml2 in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by an application linked with libxml2 could trigger a use-after-free. The greatest impact from this flaw is to confidentiality, integrity, and availability.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2021-3518?

2 open source packages ship an affected version, including nokogiri. It affects 18 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.11.4 |
| `nokogiri` | RubyGems | All versions | 1.11.4 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Clustered Data Ontap, Netapp Clustered Data Ontap Antivirus Connector, Netapp Hci H410c Firmware, Netapp Manageability Software Development Kit, Netapp Ontap Select Deploy Administration Utility, Netapp Snapdrive, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager Ops Center, Oracle Mysql Workbench, Oracle Peoplesoft Enterprise Peopletools, Oracle Real User Experience Insight, Redhat Enterprise Linux, Redhat Jboss Core Services, Xmlsoft Libxml2.

## How do I fix CVE-2021-3518?

Upgrade nokogiri to 1.11.4 or later.

## Is CVE-2021-3518 being exploited?

There is no known exploitation of CVE-2021-3518 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3518 and fix it if it is affected.

What it is: CVE-2021-3518 is a high-severity use after free vulnerability in Debian Debian Linux, published on 18 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3518 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.11.4
- nokogiri (RubyGems): affected all versions; fixed in 1.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3518/ (Markdown: https://insights.sbomify.com/CVE-2021-3518/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3518
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3518
- OSV: https://osv.dev/vulnerability/CVE-2021-3518

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3518/
Summaries are generated and may contain mistakes; the official description above is the record.
