CVE-2021-35197 Missing authorization in n/a
Blocked bot accounts can bypass sitewide blocks to purge pages via the API, allowing unauthorized cache invalidation.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-35197?
CVE-2021-35197 is a high-severity missing authorization vulnerability in Debian Debian Linux, published on 2 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In MediaWiki before 1.31.15, 1.32.x through 1.35.x before 1.35.3, and 1.36.x before 1.36.1, bots have certain unintended API access. When a bot account has a "sitewide block" applied, it is able to still "purge" pages through the MediaWiki Action API (which a "sitewide block" should have prevented).
Weakness: CWE-863
Which versions are affected by CVE-2021-35197?
1 open source package ship an affected version, including mediawiki. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
mediawiki Bitnami | All versions | 1.31.15, 1.35.3, 1.36.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Mediawiki Mediawiki.
How do I fix CVE-2021-35197?
Upgrade mediawiki to a fixed version for your release line: 1.31.15, 1.35.3 or 1.36.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-35197 being exploited?
There is no known exploitation of CVE-2021-35197 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-mediawiki-2021-35197, DEBIAN-CVE-2021-35197, GHSA-8hhg-q8jv-q9c7, MGASA-2021-0346, UBUNTU-CVE-2021-35197.