# CVE-2021-35210: Cross site scripting in the system log

> Attackers can inject malicious scripts into the system log, leading to code execution in the browser when viewed in the back end.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h58v-c6rf-g9f7

## What is CVE-2021-35210?

CVE-2021-35210 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Contao 4.5.x through 4.9.x before 4.9.16, and 4.10.x through 4.11.x before 4.11.5, allows XSS. It is possible to inject code into the tl_log table that will be executed in the browser when the system log is called in the back end.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-35210?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.10.0 | 4.11.5 |
| `contao/contao` | Packagist | From 4.10.0 | 4.11.5 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.16 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.16 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.11.5 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.11.5 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.16 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.16 |

Products: Contao Contao.

## How do I fix CVE-2021-35210?

Upgrade contao/contao to a fixed version for your release line: 4.11.5 or 4.9.16.

## Is CVE-2021-35210 being exploited?

There is no known exploitation of CVE-2021-35210 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35210 and fix it if it is affected.

What it is: CVE-2021-35210 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-35210 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.11.5
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.11.5
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.16
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.16
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.11.5
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.11.5
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.16
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35210/ (Markdown: https://insights.sbomify.com/CVE-2021-35210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35210
- OSV: https://osv.dev/vulnerability/CVE-2021-35210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35210/
Summaries are generated and may contain mistakes; the official description above is the record.
