# CVE-2021-3536: Cross-site Scripting in Wildfly

> Attackers can inject scripts via the role name field in WildFly's domain mode admin console, compromising confidentiality and integrity.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-wildfly-2021-3536, GHSA-v2wx-jj66-2hp7

## What is CVE-2021-3536?

CVE-2021-3536 is a medium-severity cross-site scripting vulnerability in Redhat Jboss Enterprise Application Platform, published on 20 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Wildfly in versions before 23.0.2.Final while creating a new role in domain mode via the admin console, it is possible to add a payload in the name field, leading to XSS. This affects Confidentiality and Integrity.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3536?

3 open source packages ship an affected version, including org.wildfly:wildfly-parent and wildfly. It affects 9 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wildfly:wildfly-parent` | Maven | All versions | 23.0.2.Final |
| `org.wildfly:wildfly-parent` | Maven | All versions | 23.0.2.Final |
| `wildfly` | Bitnami | All versions | 23.0.2 |

Products: Redhat Build of Quarkus, Redhat Data Grid, Redhat Descision Manager, Redhat Integration Camel K, Redhat Integration Camel Quarkus, Redhat Integration Service Registry, Redhat Jboss A-Mq, Redhat Jboss Enterprise Application Platform, Redhat Wildfly.

## How do I fix CVE-2021-3536?

Upgrade org.wildfly:wildfly-parent to 23.0.2.Final or later.

## Is CVE-2021-3536 being exploited?

There is no known exploitation of CVE-2021-3536 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Jboss Enterprise Application Platform

- [CVE-2022-4492](https://insights.sbomify.com/CVE-2022-4492/): Undertow client not checking server identity presented by server certificate in https connections (high 7.5)
- [CVE-2023-2974](https://insights.sbomify.com/CVE-2023-2974/): quarkus-core vulnerable to client driven TLS cipher downgrading (medium 6.5)
- [CVE-2023-1664](https://insights.sbomify.com/CVE-2023-1664/): Keycloak Untrusted Certificate Validation vulnerability (medium 6.5)
- [CVE-2021-3914](https://insights.sbomify.com/CVE-2021-3914/): SmallRye Health UI Cross-site Scripting vulnerability (medium 6.1)
- [CVE-2023-6393](https://insights.sbomify.com/CVE-2023-6393/): Quarkus: potential invalid reuse of context when @cacheresult on a uni is used (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3536 and fix it if it is affected.

What it is: CVE-2021-3536 is a medium-severity cross-site scripting vulnerability in Redhat Jboss Enterprise Application Platform, published on 20 May 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3536 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 23.0.2.Final
- org.wildfly:wildfly-parent (Maven): affected all versions; fixed in 23.0.2.Final
- wildfly (Bitnami): affected all versions; fixed in 23.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3536/ (Markdown: https://insights.sbomify.com/CVE-2021-3536/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3536
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3536
- OSV: https://osv.dev/vulnerability/CVE-2021-3536

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3536/
Summaries are generated and may contain mistakes; the official description above is the record.
