# CVE-2021-3537: Nokogiri Implements libxml2 version vulnerable to null pointer dereferencing

> An attacker can crash applications using libxml2 by providing a malicious XML document parsed in recovery mode, impacting system availability.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 May 2021
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2021-3537, DEBIAN-CVE-2021-3537, ECHO-ba64-c94d-5407, GHSA-286v-pcf5-25rc, JLSEC-2025-70, UBUNTU-CVE-2021-3537

## What is CVE-2021-3537?

CVE-2021-3537 is a medium-severity vulnerability in Debian Debian Linux, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability found in libxml2 in versions before 2.9.11 shows that it did not propagate errors while parsing XML mixed content, causing a NULL dereference. If an untrusted XML document was parsed in recovery mode and post-validated, the flaw could be used to crash the application. The highest threat from this vulnerability is to system availability.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-3537?

2 open source packages ship an affected version, including nokogiri. It affects 19 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nokogiri` | RubyGems | All versions | 1.11.4 |
| `nokogiri` | RubyGems | All versions | 1.11.4 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp Clustered Data Ontap, Netapp Clustered Data Ontap Antivirus Connector, Netapp Hci H410c Firmware, Netapp Manageability Software Development Kit, Netapp Ontap Select Deploy Administration Utility, Netapp Snapdrive, Oracle Communications Cloud Native Core Network Function Cloud Native Environment, Oracle Enterprise Manager Base Platform, Oracle Enterprise Manager Ops Center, Oracle Mysql Workbench, Oracle Openjdk, Oracle Peoplesoft Enterprise Peopletools, Oracle Real User Experience Insight, Redhat Enterprise Linux, Redhat Jboss Core Services, Xmlsoft Libxml2.

## How do I fix CVE-2021-3537?

Upgrade nokogiri to 1.11.4 or later.

## Is CVE-2021-3537 being exploited?

There is no known exploitation of CVE-2021-3537 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3537 and fix it if it is affected.

What it is: CVE-2021-3537 is a medium-severity vulnerability in Debian Debian Linux, published on 14 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3537 in the wild and no public exploit code.

Affected packages and fixed versions:
- nokogiri (RubyGems): affected all versions; fixed in 1.11.4
- nokogiri (RubyGems): affected all versions; fixed in 1.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3537/ (Markdown: https://insights.sbomify.com/CVE-2021-3537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3537
- OSV: https://osv.dev/vulnerability/CVE-2021-3537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3537/
Summaries are generated and may contain mistakes; the official description above is the record.
