# CVE-2021-3539: EspoCRM Avatar Persistent XSS

> Attackers can inject malicious scripts via avatar images in EspoCRM, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Aug 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-espocrm-2021-3539, GHSA-8v94-m4qx-qvc5

## What is CVE-2021-3539?

CVE-2021-3539 is a medium-severity cross-site scripting vulnerability in EspoCRM, published on 4 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

EspoCRM 6.1.6 and prior suffers from a persistent (type II) cross-site scripting (XSS) vulnerability in processing user-supplied avatar images. This issue was fixed in version 6.1.7 of the product.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-3539?

1 open source package ship an affected version, including espocrm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `espocrm` | Bitnami | All versions | 6.1.6 |

Products: Espocrm Espocrm.

## How do I fix CVE-2021-3539?

Upgrade espocrm to 6.1.6 or later.

## Is CVE-2021-3539 being exploited?

There is no known exploitation of CVE-2021-3539 in the wild and no public exploit code.

## Other vulnerabilities in EspoCRM

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3539 and fix it if it is affected.

What it is: CVE-2021-3539 is a medium-severity cross-site scripting vulnerability in EspoCRM, published on 4 Aug 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-3539 in the wild and no public exploit code.

Affected packages and fixed versions:
- espocrm (Bitnami): affected all versions; fixed in 6.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3539/ (Markdown: https://insights.sbomify.com/CVE-2021-3539/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3539
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3539
- OSV: https://osv.dev/vulnerability/CVE-2021-3539

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3539/
Summaries are generated and may contain mistakes; the official description above is the record.
