{"answers":{"affected":"2 open source packages ship an affected version, including smashing. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-35440 in the wild and no public exploit code.","fix":"Upgrade smashing to 1.3.5 or later.","what":"CVE-2021-35440 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-35440 and fix it if it is affected.\n\nWhat it is: CVE-2021-35440 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Jul 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-35440 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- smashing (RubyGems): affected all versions; fixed in 1.3.5\n- smashing (RubyGems): affected all versions; fixed in 1.3.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-35440/ (Markdown: https://insights.sbomify.com/CVE-2021-35440/index.md)","id":"CVE-2021-35440","markdown":"https://insights.sbomify.com/CVE-2021-35440/index.md","name":"CVE-2021-35440","record":{"aliases":["GHSA-254j-mmc5-qhpx"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Smashing Ruby library","requires_auth":"none","summary":"Attackers can execute JavaScript via crafted widget URLs to steal session data and private information from victims using the Smashing library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"smashing","vendor":"smashing_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Smashing 1.3.4 is vulnerable to Cross Site Scripting (XSS). A URL for a widget can be crafted and used to execute JavaScript on the victim's computer. The JavaScript code can then steal data available in the session/cookies depending on the user environment (e.g. if re-using internal URL's for deploying, or cookies that are very permissive) private information may be retrieved by the attacker.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Smashing Cross-site Scripting vulnerability","id":"CVE-2021-35440","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2021-35448"},"packages":[{"ecosystem":"RubyGems","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"smashing","purl":null,"source":"GHSA-254j-mmc5-qhpx"},{"ecosystem":"RubyGems","fixed":["1.3.5"],"introduced":["0"],"last_affected":[],"package":"smashing","purl":"pkg:gem/smashing","source":"GHSA-254j-mmc5-qhpx"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-35438"},"products":["n/a"],"published":"2021-07-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can execute JavaScript via crafted widget URLs to steal session data and private information from victims using the Smashing library.","url":"https://insights.sbomify.com/CVE-2021-35440/"}