# CVE-2021-35514: Code injection in Narou

> Attackers can execute arbitrary Ruby code by injecting malicious payloads into novel title or author fields in the Narou library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jun 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-gwrj-88fp-5m36

## What is CVE-2021-35514?

CVE-2021-35514 is a critical code injection vulnerability in n/a, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Narou (aka Narou.rb) before 3.8.0 allows Ruby Code Injection via the title name or author name of a novel.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-35514?

2 open source packages ship an affected version, including narou. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `narou` | RubyGems | All versions | 3.8.0 |
| `narou` | RubyGems | All versions | 3.8.0 |

Products: Narou Project Narou.

## How do I fix CVE-2021-35514?

Upgrade narou to 3.8.0 or later.

## Is CVE-2021-35514 being exploited?

There is no known exploitation of CVE-2021-35514 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35514 and fix it if it is affected.

What it is: CVE-2021-35514 is a critical code injection vulnerability in n/a, published on 28 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-35514 in the wild and no public exploit code.

Affected packages and fixed versions:
- narou (RubyGems): affected all versions; fixed in 3.8.0
- narou (RubyGems): affected all versions; fixed in 3.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35514/ (Markdown: https://insights.sbomify.com/CVE-2021-35514/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35514
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35514
- OSV: https://osv.dev/vulnerability/CVE-2021-35514

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35514/
Summaries are generated and may contain mistakes; the official description above is the record.
