CVE-2021-35565 Denial of service in Java SE JDK and JRE
Unauthenticated attackers can cause a partial denial of service in Java SE and GraalVM via TLS network access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-35565?
CVE-2021-35565 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 7u311, 8u301, 11.0.12; Oracle GraalVM Enterprise Edition: 20.3.3 and 21.2.0. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).
Which versions are affected by CVE-2021-35565?
3 open source packages ship an affected version, including java, java-min and jre. It affects 14 products.
| Package | Affected | Fixed in |
|---|---|---|
java Bitnami | All versions | 1.7.0, 1.8.0, 7.0.321, 8.0.311, 11.0.13 |
java-min Bitnami | All versions | 1.7.0, 1.8.0, 7.0.321, 8.0.311, 11.0.13 |
jre Bitnami | All versions | 1.7.0, 1.8.0, 7.0.321, 8.0.311, 11.0.13 |
Products include Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Web Services and 8 more.
How do I fix CVE-2021-35565?
Upgrade java to a fixed version for your release line: 1.7.0, 1.8.0, 7.0.321 or 8.0.311.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-35565 being exploited?
There is no known exploitation of CVE-2021-35565 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-java-2021-35565, BIT-java-min-2021-35565, BIT-jre-2021-35565, CLEANSTART-2026-IE68111, CLEANSTART-2026-QL58432, DEBIAN-CVE-2021-35565 and 5 more.