# CVE-2021-35578: Denial of service in Java SE JDK and JRE

> Unauthenticated attackers can cause a partial denial of service in Java SE and GraalVM via TLS network access.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Oct 2021
- **Updated:** 22 Aug 2024
- **Also known as:** BIT-java-2021-35578, BIT-java-min-2021-35578, BIT-jre-2021-35578, CLEANSTART-2026-IT12075, CLEANSTART-2026-NY44309, DEBIAN-CVE-2021-35578, GHSA-2rqw-4rc9-x55v, MINI-23qx-4c8q-mcqw, MINI-2jwm-58v3-7qr5, MINI-7crf-f46w-7969, MINI-8m5x-gh8q-jmmh, MINI-9h22-gv9r-8382, MINI-h3vv-67qp-82qm, MINI-px36-9jj5-qp38, MINI-rx7c-v6m2-g689, UBUNTU-CVE-2021-35578

## What is CVE-2021-35578?

CVE-2021-35578 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vulnerability in the Java SE, Oracle GraalVM Enterprise Edition product of Oracle Java SE (component: JSSE). Supported versions that are affected are Java SE: 8u301, 11.0.12, 17; Oracle GraalVM Enterprise Edition: 20.3.3 and 21.2.0. Easily exploitable vulnerability allows unauthenticated attacker with network access via TLS to compromise Java SE, Oracle GraalVM Enterprise Edition. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Oracle GraalVM Enterprise Edition. Note: This vulnerability can only be exploited by supplying data to APIs in the specified Component without using Untrusted Java Web Start applications or Untrusted Java applets, such as through a web service. CVSS 3.1 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

## Which versions are affected by CVE-2021-35578?

3 open source packages ship an affected version, including java, java-min and jre. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `java` | Bitnami | All versions | 1.8.0, 8.0.311, 11.0.13, 17.0.1 |
| `java-min` | Bitnami | All versions | 1.8.0, 8.0.311, 11.0.13, 17.0.1 |
| `jre` | Bitnami | All versions | 1.8.0, 8.0.311, 11.0.13, 17.0.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Netapp Active Iq Unified Manager, Netapp E-Series Santricity Os Controller, Netapp E-Series Santricity Storage Manager, Netapp E-Series Santricity Web Services, Netapp Hci Management Node, Netapp Oncommand Insight, Netapp Oncommand Workflow Automation, Netapp Santricity Unified Manager, Netapp Snapmanager, Netapp Solidfire, Oracle Graalvm, Oracle Openjdk.

## How do I fix CVE-2021-35578?

Upgrade java to a fixed version for your release line: 1.8.0, 8.0.311, 11.0.13 or 17.0.1.

## Is CVE-2021-35578 being exploited?

There is no known exploitation of CVE-2021-35578 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35578 and fix it if it is affected.

What it is: CVE-2021-35578 is a medium-severity denial of service vulnerability in Debian Debian Linux, published on 20 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-35578 in the wild and no public exploit code.

Affected packages and fixed versions:
- java (Bitnami): affected all versions; fixed in 1.8.0, 8.0.311, 11.0.13, 17.0.1
- java-min (Bitnami): affected all versions; fixed in 1.8.0, 8.0.311, 11.0.13, 17.0.1
- jre (Bitnami): affected all versions; fixed in 1.8.0, 8.0.311, 11.0.13, 17.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35578/ (Markdown: https://insights.sbomify.com/CVE-2021-35578/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35578
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35578
- OSV: https://osv.dev/vulnerability/CVE-2021-35578

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35578/
Summaries are generated and may contain mistakes; the official description above is the record.
