CVE-2021-35604 Denial of service in MySQL Server
High-privileged attackers can cause MySQL Server crashes and modify data via network access, requiring immediate patching.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-35604?
CVE-2021-35604 is a medium-severity denial of service vulnerability in Fedoraproject Fedora, published on 20 Oct 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Vulnerability in the MySQL Server product of Oracle MySQL (component: InnoDB). Supported versions that are affected are 5.7.35 and prior and 8.0.26 and prior. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server as well as unauthorized update, insert or delete access to some of MySQL Server accessible data. CVSS 3.1 Base Score 5.5 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:H).
Which versions are affected by CVE-2021-35604?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 5 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.2.0 | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.3 |
mariadb-min Bitnami | From 10.2.0 | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.3 |
mysql-client Bitnami | From 10.2.0 | 10.2.41, 10.3.32, 10.4.22, 10.5.13, 10.6.3 |
Linux distribution packages (20)
mariadb SUSE:Enterprise Storage 6 | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise Module for Server Applications 15 SP2 | All versions | 10.4.22-3.22.1 |
mariadb SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 10.5.13-3.12.1 |
mariadb SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 10.2.41-3.44.3 |
mariadb SUSE:Linux Enterprise Server 12 SP5 | All versions | 10.2.41-3.44.3 |
mariadb SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise Server 15-LTSS | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 10.2.41-3.44.3 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 10.2.41-3.44.3 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 10.2.41-3.48.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 10.2.41-3.48.1 |
mariadb SUSE:OpenStack Cloud 9 | All versions | 10.2.41-3.44.3 |
mariadb SUSE:OpenStack Cloud Crowbar 9 | All versions | 10.2.41-3.44.3 |
mariadb openSUSE:Leap 15.3 | All versions | 10.5.13-3.12.1 |
mariadb openSUSE:Tumbleweed | All versions | 10.6.5-1.1 |
Products include Fedoraproject Fedora, Mariadb Mariadb, Netapp Oncommand Insight, Netapp Snapcenter, Oracle Mysql Server.
How do I fix CVE-2021-35604?
Upgrade mariadb to a fixed version for your release line: 10.2.41, 10.3.32, 10.4.22 or 10.5.13.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-35604 being exploited?
There is no known exploitation of CVE-2021-35604 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as ALPINE-CVE-2021-35604, BIT-mariadb-2021-35604, BIT-mariadb-min-2021-35604, BIT-mysql-client-2021-35604, DEBIAN-CVE-2021-35604, GHSA-c9rm-w869-vhx6 and 9 more.