{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-3571 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2021-3571 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3571 and fix it if it is affected.\n\nWhat it is: CVE-2021-3571 is a high-severity vulnerability in Fedoraproject Fedora, published on 9 Jul 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3571 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3571/ (Markdown: https://insights.sbomify.com/CVE-2021-3571/index.md)","id":"CVE-2021-3571","markdown":"https://insights.sbomify.com/CVE-2021-3571/index.md","name":"CVE-2021-3571","record":{"aliases":["ALSA-2021:4321","DEBIAN-CVE-2021-3571","GHSA-3v9q-m45q-4cr7","OESA-2021-1267","RHSA-2021:4321","RLSA-2021:4321"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Linux PTP daemon","requires_auth":"low_privilege","summary":"A remote attacker can cause an information leak or crash in ptp4l by sending crafted messages when running as a transparent clock on little-endian systems.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"linuxptp","vendor":"linuxptp_project"},{"product":"enterprise_linux","vendor":"redhat"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A flaw was found in the ptp4l program of the linuxptp package. When ptp4l is operating on a little-endian architecture as a PTP transparent clock, a remote attacker could send a crafted one-step sync message to cause an information leak or crash. The highest threat from this vulnerability is to data confidentiality and system availability. This flaw affects linuxptp versions before 3.1.1 and before 2.0.1.","ecosystems":["AlmaLinux:8","Red Hat:enterprise_linux:8::appstream","Rocky Linux:8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in linuxptp","id":"CVE-2021-3571","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora","redhat:enterprise_linux"],"type":"information_disclosure","year":"2021"},"n_packages":5,"n_references":3,"next":{"headline":"Improper Input Validation in pip","id":"CVE-2021-3572"},"packages":[{"ecosystem":"AlmaLinux:8","fixed":["3.1.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"linuxptp","purl":"pkg:rpm/almalinux/linuxptp","source":"ALSA-2021:4321"},{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.1.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"linuxptp","purl":"pkg:rpm/redhat/linuxptp","source":"RHSA-2021:4321"},{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.1.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"linuxptp-debuginfo","purl":"pkg:rpm/redhat/linuxptp-debuginfo","source":"RHSA-2021:4321"},{"ecosystem":"Red Hat:enterprise_linux:8::appstream","fixed":["0:3.1.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"linuxptp-debugsource","purl":"pkg:rpm/redhat/linuxptp-debugsource","source":"RHSA-2021:4321"},{"ecosystem":"Rocky Linux:8","fixed":["0:3.1.1-1.el8"],"introduced":["0"],"last_affected":[],"package":"linuxptp","purl":"pkg:rpm/rocky-linux/linuxptp?distro=rocky-linux-8-5-legacy\u0026epoch=0","source":"RLSA-2021:4321"}],"prev":{"headline":"Memory corruption in linuxptp","id":"CVE-2021-3570"},"products":["linuxptp"],"published":"2021-07-09","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"A remote attacker can cause an information leak or crash in ptp4l by sending crafted messages when running as a transparent clock on little-endian systems.","url":"https://insights.sbomify.com/CVE-2021-3571/"}