# CVE-2021-3584: Command injection in foreman

> An authenticated attacker can exploit Sendmail configuration options to perform command injection, leading to remote code execution and system compromise.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x4xp-c8qv-8gww

## What is CVE-2021-3584?

CVE-2021-3584 is a high-severity command injection vulnerability in Redhat Satellite, published on 23 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A server side remote code execution vulnerability was found in Foreman project. A authenticated attacker could use Sendmail configuration options to overwrite the defaults and perform command injection. The highest threat from this vulnerability is to confidentiality, integrity and availability of system. Fixed releases are 2.4.1, 2.5.1, 3.0.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-3584?

It affects 2 products.


Products: Redhat Satellite, Theforeman Foreman.

## How do I fix CVE-2021-3584?

Upgrade to a fixed version.

## Is CVE-2021-3584 being exploited?

There is no known exploitation of CVE-2021-3584 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Satellite

- [CVE-2024-7012](https://insights.sbomify.com/CVE-2024-7012/): Puppet-foreman: an authentication bypass vulnerability exists in foreman (critical 9.8)
- [CVE-2024-7923](https://insights.sbomify.com/CVE-2024-7923/): Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore (critical 9.8)
- [CVE-2026-96659](https://insights.sbomify.com/CVE-2026-96659/): Foreman: excessive permissions for viewer role on preview (critical 9.1)
- [CVE-2023-0118](https://insights.sbomify.com/CVE-2023-0118/): Foreman: arbitrary code execution through templates (critical 9.1)
- [CVE-2008-2369](https://insights.sbomify.com/CVE-2008-2369/): Hardcoded credentials in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3584 and fix it if it is affected.

What it is: CVE-2021-3584 is a high-severity command injection vulnerability in Redhat Satellite, published on 23 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3584 in the wild and no public exploit code.

Affected product: Redhat Satellite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3584/ (Markdown: https://insights.sbomify.com/CVE-2021-3584/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3584
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3584
- OSV: https://osv.dev/vulnerability/CVE-2021-3584

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3584/
Summaries are generated and may contain mistakes; the official description above is the record.
