# CVE-2021-3589: Missing Authentication for Critical Function in Foreman Ansible

> Authenticated attackers with job creation permissions can bypass authorization to access hosts via job templates, compromising confidentiality, integrity, and availability.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vvff-6wrr-4g7q

## What is CVE-2021-3589?

CVE-2021-3589 is a high-severity missing authorization vulnerability in Redhat Satellite, published on 23 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An authorization flaw was found in Foreman Ansible. An authenticated attacker with certain permissions to create and run Ansible jobs can access hosts through job templates. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2021-3589?

2 open source packages ship an affected version, including foreman_ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `foreman_ansible` | RubyGems | All versions | 2.0.0 |
| `foreman_ansible` | RubyGems | All versions | 2.0.0 |

Products: Redhat Satellite, Theforeman Foreman Ansible.

## How do I fix CVE-2021-3589?

Upgrade foreman_ansible to 2.0.0 or later.

## Is CVE-2021-3589 being exploited?

There is no known exploitation of CVE-2021-3589 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Satellite

- [CVE-2024-7012](https://insights.sbomify.com/CVE-2024-7012/): Puppet-foreman: an authentication bypass vulnerability exists in foreman (critical 9.8)
- [CVE-2024-7923](https://insights.sbomify.com/CVE-2024-7923/): Puppet-pulpcore: an authentication bypass vulnerability exists in pulpcore (critical 9.8)
- [CVE-2026-96659](https://insights.sbomify.com/CVE-2026-96659/): Foreman: excessive permissions for viewer role on preview (critical 9.1)
- [CVE-2023-0118](https://insights.sbomify.com/CVE-2023-0118/): Foreman: arbitrary code execution through templates (critical 9.1)
- [CVE-2008-2369](https://insights.sbomify.com/CVE-2008-2369/): Hardcoded credentials in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3589 and fix it if it is affected.

What it is: CVE-2021-3589 is a high-severity missing authorization vulnerability in Redhat Satellite, published on 23 Mar 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3589 in the wild and no public exploit code.

Affected packages and fixed versions:
- foreman_ansible (RubyGems): affected all versions; fixed in 2.0.0
- foreman_ansible (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3589/ (Markdown: https://insights.sbomify.com/CVE-2021-3589/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3589
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3589
- OSV: https://osv.dev/vulnerability/CVE-2021-3589

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3589/
Summaries are generated and may contain mistakes; the official description above is the record.
