CVE-2021-35940 Regression of CVE-2017-12613

High 7.1 Published Updated

An out-of-bounds array read in APR time functions can cause crashes or leak memory, affecting applications using the library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-35940?

CVE-2021-35940 is a high-severity memory corruption vulnerability in Oracle Http Server, published on 23 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Weakness: CWE-125

Which versions are affected by CVE-2021-35940?

1 open source package ship an affected version, including apr. It affects 2 products.

PackageAffectedFixed in
apr BitnamiFrom 1.7.01.7.1
Linux distribution packages (1)
apr openSUSE:TumbleweedAll versions1.7.0-4.1

Products include Apache Portable Runtime, Oracle Http Server.

How do I fix CVE-2021-35940?

Upgrade apr to 1.7.1 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2021-35940 being exploited?

There is no known exploitation of CVE-2021-35940 in the wild and no public exploit code.

All Oracle Http Server vulnerabilities

Sources

Also known as ALPINE-CVE-2021-35940, BIT-apr-2021-35940, DEBIAN-CVE-2021-35940, GHSA-95qq-4mqm-pp5g, MGASA-2021-0428, UBUNTU-CVE-2021-35940 and 2 more.

Is CVE-2021-35940 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free