{"answers":{"affected":"1 open source package ship an affected version, including apr. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-35940 in the wild and no public exploit code.","fix":"Upgrade apr to 1.7.1 or later.","what":"CVE-2021-35940 is a high-severity memory corruption vulnerability in Oracle Http Server, published on 23 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-35940 and fix it if it is affected.\n\nWhat it is: CVE-2021-35940 is a high-severity memory corruption vulnerability in Oracle Http Server, published on 23 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-35940 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apr (Bitnami): affected from 1.7.0; fixed in 1.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-35940/ (Markdown: https://insights.sbomify.com/CVE-2021-35940/index.md)","id":"CVE-2021-35940","markdown":"https://insights.sbomify.com/CVE-2021-35940/index.md","name":"CVE-2021-35940","record":{"aliases":["ALPINE-CVE-2021-35940","BIT-apr-2021-35940","DEBIAN-CVE-2021-35940","GHSA-95qq-4mqm-pp5g","MGASA-2021-0428","UBUNTU-CVE-2021-35940","USN-5056-1","openSUSE-SU-2024:11865-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache Portable Runtime","requires_auth":"low_privilege","summary":"An out-of-bounds array read in APR time functions can cause crashes or leak memory, affecting applications using the library.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"portable_runtime","vendor":"apache"},{"product":"http_server","vendor":"oracle"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.","ecosystems":["Bitnami","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Regression of CVE-2017-12613","id":"CVE-2021-35940","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"oracle:http_server","products":["oracle:http_server"],"type":"memory_corruption","year":"2021"},"n_packages":2,"n_references":17,"next":{"headline":"Missing authorization in n/a","id":"CVE-2021-35941"},"packages":[{"ecosystem":"Bitnami","fixed":["1.7.1"],"introduced":["1.7.0"],"last_affected":[],"package":"apr","purl":"pkg:bitnami/apr","source":"BIT-apr-2021-35940"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.7.0-4.1"],"introduced":["0"],"last_affected":[],"package":"apr","purl":"pkg:rpm/opensuse/apr\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:11865-1"}],"prev":{"headline":"Privilege escalation in RPM","id":"CVE-2021-35939"},"products":["Apache Portable Runtime (APR)"],"published":"2021-08-23","related":[{"cvss_score":9.8,"headline":"Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions","id":"CVE-2022-24963","kev_date_added":null,"published":"2023-01-31"},{"cvss_score":9.8,"headline":"Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function","id":"CVE-2022-28331","kev_date_added":null,"published":"2023-01-31"},{"cvss_score":7.1,"headline":"Information disclosure in Apache Portable Runtime","id":"CVE-2017-12613","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":5.5,"headline":"Apache Portable Runtime (APR): Unexpected lax shared memory permissions","id":"CVE-2023-49582","kev_date_added":null,"published":"2024-08-26"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2012-0840","kev_date_added":null,"published":"2012-02-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"An out-of-bounds array read in APR time functions can cause crashes or leak memory, affecting applications using the library.","url":"https://insights.sbomify.com/CVE-2021-35940/"}