# CVE-2021-35940: Regression of CVE-2017-12613

> An out-of-bounds array read in APR time functions can cause crashes or leak memory, affecting applications using the library.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2021-35940, BIT-apr-2021-35940, DEBIAN-CVE-2021-35940, GHSA-95qq-4mqm-pp5g, MGASA-2021-0428, UBUNTU-CVE-2021-35940, USN-5056-1, openSUSE-SU-2024:11865-1

## What is CVE-2021-35940?

CVE-2021-35940 is a high-severity memory corruption vulnerability in Oracle Http Server, published on 23 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An out-of-bounds array read in the apr_time_exp*() functions was fixed in the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for this issue was not carried forward to the APR 1.7.x branch, and hence version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same issue.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-35940?

1 open source package ship an affected version, including apr. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apr` | Bitnami | From 1.7.0 | 1.7.1 |
| `apr` | openSUSE:Tumbleweed | All versions | 1.7.0-4.1 |

Products: Apache Portable Runtime, Oracle Http Server.

## How do I fix CVE-2021-35940?

Upgrade apr to 1.7.1 or later.

## Is CVE-2021-35940 being exploited?

There is no known exploitation of CVE-2021-35940 in the wild and no public exploit code.

## Other vulnerabilities in Oracle Http Server

- [CVE-2022-24963](https://insights.sbomify.com/CVE-2022-24963/): Apache Portable Runtime (APR): out-of-bound writes in the apr_encode family of functions (critical 9.8)
- [CVE-2022-28331](https://insights.sbomify.com/CVE-2022-28331/): Apache Portable Runtime (APR): Windows out-of-bounds write in apr_socket_sendv function (critical 9.8)
- [CVE-2017-12613](https://insights.sbomify.com/CVE-2017-12613/): Information disclosure in Apache Portable Runtime (high 7.1)
- [CVE-2023-49582](https://insights.sbomify.com/CVE-2023-49582/): Apache Portable Runtime (APR): Unexpected lax shared memory permissions (medium 5.5)
- [CVE-2012-0840](https://insights.sbomify.com/CVE-2012-0840/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35940 and fix it if it is affected.

What it is: CVE-2021-35940 is a high-severity memory corruption vulnerability in Oracle Http Server, published on 23 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-35940 in the wild and no public exploit code.

Affected packages and fixed versions:
- apr (Bitnami): affected from 1.7.0; fixed in 1.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35940/ (Markdown: https://insights.sbomify.com/CVE-2021-35940/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35940
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35940
- OSV: https://osv.dev/vulnerability/CVE-2021-35940

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35940/
Summaries are generated and may contain mistakes; the official description above is the record.
