CVE-2021-35955 Cross site scripting via HTML attributes in the back end
An attacker can inject malicious scripts into backend HTML fields, potentially leading to code execution or account takeover in Contao CMS.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-35955?
CVE-2021-35955 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Aug 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.
Weakness: CWE-79
Which versions are affected by CVE-2021-35955?
12 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 4.0.0 | 4.4.56 |
contao/contao Packagist | From 4.0.0 | 4.4.56 |
contao/contao Packagist | From 4.10.0 | 4.11.7 |
contao/contao Packagist | From 4.10.0 | 4.11.7 |
contao/contao Packagist | From 4.5.0 | 4.9.18 |
contao/contao Packagist | From 4.5.0 | 4.9.18 |
6 more packages
contao/core-bundle Packagist | From 4.0.0 | 4.4.56 |
contao/core-bundle Packagist | From 4.0.0 | 4.4.56 |
contao/core-bundle Packagist | From 4.10.0 | 4.11.7 |
contao/core-bundle Packagist | From 4.10.0 | 4.11.7 |
contao/core-bundle Packagist | From 4.5.0 | 4.9.18 |
contao/core-bundle Packagist | From 4.5.0 | 4.9.18 |
Products include Contao Contao.
How do I fix CVE-2021-35955?
Upgrade contao/contao to a fixed version for your release line: 4.4.56, 4.11.7 or 4.9.18.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-35955 being exploited?
There is no known exploitation of CVE-2021-35955 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-hr3h-x6gq-rqcp.