# CVE-2021-35955: Cross site scripting via HTML attributes in the back end

> An attacker can inject malicious scripts into backend HTML fields, potentially leading to code execution or account takeover in Contao CMS.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 12 Aug 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hr3h-x6gq-rqcp

## What is CVE-2021-35955?

CVE-2021-35955 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Aug 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Contao >=4.0.0 allows backend XSS via HTML attributes to an HTML field. Fixed in 4.4.56, 4.9.18, 4.11.7.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-35955?

12 open source packages ship an affected version, including contao/contao and contao/core-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.56 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.56 |
| `contao/contao` | Packagist | From 4.10.0 | 4.11.7 |
| `contao/contao` | Packagist | From 4.10.0 | 4.11.7 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.18 |
| `contao/contao` | Packagist | From 4.5.0 | 4.9.18 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.56 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.56 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.11.7 |
| `contao/core-bundle` | Packagist | From 4.10.0 | 4.11.7 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.18 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.9.18 |

Products: Contao Contao.

## How do I fix CVE-2021-35955?

Upgrade contao/contao to a fixed version for your release line: 4.4.56, 4.11.7 or 4.9.18.

## Is CVE-2021-35955 being exploited?

There is no known exploitation of CVE-2021-35955 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-35955 and fix it if it is affected.

What it is: CVE-2021-35955 is a medium-severity cross-site scripting vulnerability in n/a, published on 12 Aug 2021. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-35955 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.56
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.56
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.11.7
- contao/contao (Packagist): affected from 4.10.0; fixed in 4.11.7
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.18
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.9.18
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.56
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.56
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.11.7
- contao/core-bundle (Packagist): affected from 4.10.0; fixed in 4.11.7
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.18
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.9.18

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-35955/ (Markdown: https://insights.sbomify.com/CVE-2021-35955/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-35955
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-35955
- OSV: https://osv.dev/vulnerability/CVE-2021-35955

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-35955/
Summaries are generated and may contain mistakes; the official description above is the record.
