CVE-2021-36021 Magento Commerce CMS Page Improper Input Validation Could Lead To Remote Code Execution
An authenticated administrator can achieve remote code execution via improper input validation in the CMS page scheduled update feature.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-36021?
CVE-2021-36021 is a high-severity code injection vulnerability in Magento Magento, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Magento versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper input validation vulnerability within the CMS page scheduled update feature. An authenticated attacker with administrative privilege could leverage this vulnerability to achieve remote code execution on the system.
Weakness: CWE-20
Which versions are affected by CVE-2021-36021?
9 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
3 more packages
magento Bitnami | All versions | 2.3.7, 2.4.2 |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Magento Magento.
How do I fix CVE-2021-36021?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2021-36021 being exploited?
There is no known exploitation of CVE-2021-36021 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2021-36021, GHSA-4g27-q2w9-m8m8.