# CVE-2021-36021: Magento Commerce CMS Page Improper Input Validation Could Lead To Remote Code Execution

> An authenticated administrator can achieve remote code execution via improper input validation in the CMS page scheduled update feature.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2023
- **Updated:** 13 Sep 2024
- **Also known as:** BIT-magento-2021-36021, GHSA-4g27-q2w9-m8m8

## What is CVE-2021-36021?

CVE-2021-36021 is a high-severity code injection vulnerability in Magento Magento, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an Improper input validation vulnerability within the CMS page scheduled update feature. An authenticated attacker with administrative privilege could leverage this vulnerability to achieve remote code execution on the system.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-36021?

9 open source packages ship an affected version, including magento/community-edition, magento and magento/project-community-edition. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento` | Bitnami | All versions | 2.3.7, 2.4.2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Magento Magento.

## How do I fix CVE-2021-36021?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.

## Is CVE-2021-36021 being exploited?

There is no known exploitation of CVE-2021-36021 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36021 and fix it if it is affected.

What it is: CVE-2021-36021 is a high-severity code injection vulnerability in Magento Magento, published on 6 Sep 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36021 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento (Bitnami): affected all versions; fixed in 2.3.7, 2.4.2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36021/ (Markdown: https://insights.sbomify.com/CVE-2021-36021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36021
- OSV: https://osv.dev/vulnerability/CVE-2021-36021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36021/
Summaries are generated and may contain mistakes; the official description above is the record.
