CVE-2021-36026 Magento Commerce Stored Cross-site Scripting Vulnerability
Attackers can inject malicious scripts into customer address fields, leading to JavaScript execution in victims' browsers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-36026?
CVE-2021-36026 is a medium-severity cross-site scripting vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by a stored cross-site scripting vulnerability in the customer address upload feature that could be abused by an attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Weakness: CWE-79
Which versions are affected by CVE-2021-36026?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
2 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Adobe Adobe Commerce, Adobe Magento Open Source.
How do I fix CVE-2021-36026?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-36026 being exploited?
There is no known exploitation of CVE-2021-36026 in the wild and no public exploit code.
Other vulnerabilities in Adobe Magento Commerce
- CVE-2021-36022 Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36024 Magento Commerce Improper Neutralization of Special Elements Used In A Command
- CVE-2021-36025 Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution
- CVE-2021-36028 Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36029 Magento Commerce Improper Authorization Vulnerability Could Lead To Remote Code Execution
Sources
Also known as GHSA-8gfq-m4cf-w975.