{"answers":{"affected":"3 open source packages ship an affected version, including phpmailer/phpmailer and phpmailer. It affects 2 products.","exploited":"There is no known exploitation of CVE-2021-3603 in the wild and no public exploit code.","fix":"Upgrade phpmailer/phpmailer to 6.5.0 or later.","what":"CVE-2021-3603 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 17 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-3603 and fix it if it is affected.\n\nWhat it is: CVE-2021-3603 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 17 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-3603 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0\n- phpmailer (Bitnami): affected all versions; fixed in 6.4.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-3603/ (Markdown: https://insights.sbomify.com/CVE-2021-3603/index.md)","id":"CVE-2021-3603","markdown":"https://insights.sbomify.com/CVE-2021-3603/index.md","name":"CVE-2021-3603","record":{"aliases":["BIT-phpmailer-2021-3603","DEBIAN-CVE-2021-3603","GHSA-77mr-wc79-m8j3","MGASA-2021-0345","UBUNTU-CVE-2021-3603"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP email library","requires_auth":"none","summary":"Attackers can execute arbitrary code if a malicious function named 'php' exists in the global namespace, affecting PHPMailer users.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"phpmailer","vendor":"phpmailer_project"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"PHPMailer 6.4.1 and earlier contain a vulnerability that can result in untrusted code being called (if such code is injected into the host project's scope by other means). If the $patternselect parameter to validateAddress() is set to 'php' (the default, defined by PHPMailer::$validator), and the global namespace contains a function called php, it will be called in preference to the built-in validator of the same name. Mitigated in PHPMailer 6.5.0 by denying the use of simple strings as validator function names.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Inclusion of Functionality from Untrusted Control Sphere in PHPMailer/PHPMailer","id":"CVE-2021-3603","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"code_injection","year":"2021"},"n_packages":3,"n_references":4,"next":{"headline":"Primion-Digitek Secure 8 SQL injection vulnerability","id":"CVE-2021-3604"},"packages":[{"ecosystem":"Bitnami","fixed":["6.4.2"],"introduced":["0"],"last_affected":[],"package":"phpmailer","purl":"pkg:bitnami/phpmailer","source":"BIT-phpmailer-2021-3603"},{"ecosystem":"Packagist","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":null,"source":"GHSA-77mr-wc79-m8j3"},{"ecosystem":"Packagist","fixed":["6.5.0"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":"pkg:composer/phpmailer/phpmailer","source":"GHSA-77mr-wc79-m8j3"}],"prev":{"headline":"Buildah processes using chroot isolation may leak environment values to intermediate processes","id":"CVE-2021-3602"},"products":["PHPMailer"],"published":"2021-06-17","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["PHPMailer"]},"summary":"Attackers can execute arbitrary code if a malicious function named 'php' exists in the global namespace, affecting PHPMailer users.","url":"https://insights.sbomify.com/CVE-2021-3603/"}