# CVE-2021-3603: Inclusion of Functionality from Untrusted Control Sphere in PHPMailer/PHPMailer

> Attackers can execute arbitrary code if a malicious function named 'php' exists in the global namespace, affecting PHPMailer users.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-phpmailer-2021-3603, DEBIAN-CVE-2021-3603, GHSA-77mr-wc79-m8j3, MGASA-2021-0345, UBUNTU-CVE-2021-3603

## What is CVE-2021-3603?

CVE-2021-3603 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 17 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHPMailer 6.4.1 and earlier contain a vulnerability that can result in untrusted code being called (if such code is injected into the host project's scope by other means). If the $patternselect parameter to validateAddress() is set to 'php' (the default, defined by PHPMailer::$validator), and the global namespace contains a function called php, it will be called in preference to the built-in validator of the same name. Mitigated in PHPMailer 6.5.0 by denying the use of simple strings as validator function names.

Weakness: CWE-829 (Inclusion of Functionality from Untrusted Control Sphere)

## Which versions are affected by CVE-2021-3603?

3 open source packages ship an affected version, including phpmailer/phpmailer and phpmailer. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 6.5.0 |
| `phpmailer/phpmailer` | Packagist | All versions | 6.5.0 |
| `phpmailer` | Bitnami | All versions | 6.4.2 |

Products: Fedoraproject Fedora, Phpmailer Project Phpmailer.

## How do I fix CVE-2021-3603?

Upgrade phpmailer/phpmailer to 6.5.0 or later.

## Is CVE-2021-3603 being exploited?

There is no known exploitation of CVE-2021-3603 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-3603 and fix it if it is affected.

What it is: CVE-2021-3603 is a high-severity code injection vulnerability in Fedoraproject Fedora, published on 17 Jun 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-3603 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 6.5.0
- phpmailer (Bitnami): affected all versions; fixed in 6.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-3603/ (Markdown: https://insights.sbomify.com/CVE-2021-3603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-3603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-3603
- OSV: https://osv.dev/vulnerability/CVE-2021-3603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-3603/
Summaries are generated and may contain mistakes; the official description above is the record.
