CVE-2021-36032 Magento Commerce Improper Input Validation Could Lead To Information Exposure and Privilege Escalation
An authenticated attacker can exploit improper input validation in the customer endpoint to access sensitive data and escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-36032?
CVE-2021-36032 is a high-severity missing authorization vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An authenticated attacker can trigger an insecure direct object reference in the `V1/customers/me` endpoint to achieve information exposure and privilege escalation.
Which versions are affected by CVE-2021-36032?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
2 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Adobe Adobe Commerce, Adobe Magento Open Source.
How do I fix CVE-2021-36032?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2021-36032 being exploited?
There is no known exploitation of CVE-2021-36032 in the wild and no public exploit code.
Other vulnerabilities in Adobe Magento Commerce
- CVE-2021-36022 Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36024 Magento Commerce Improper Neutralization of Special Elements Used In A Command
- CVE-2021-36025 Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution
- CVE-2021-36028 Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36029 Magento Commerce Improper Authorization Vulnerability Could Lead To Remote Code Execution
Sources
Also known as GHSA-5vw8-r55w-f4q4.