# CVE-2021-36033: Magento Commerce Widgets Module XML Injection Vulnerability Could Lead To Remote Code Execution

> An admin attacker can exploit an XML injection flaw in the Widgets Module to achieve remote code execution on Magento Commerce.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p746-qw73-qmmx

## What is CVE-2021-36033?

CVE-2021-36033 is a critical vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an XML Injection vulnerability in the Widgets Module. An attacker with admin privileges can trigger a specially crafted script to achieve remote code execution.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2021-36033?

8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Adobe Commerce, Adobe Magento Open Source.

## How do I fix CVE-2021-36033?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.

## Is CVE-2021-36033 being exploited?

There is no known exploitation of CVE-2021-36033 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Magento Commerce

- [CVE-2021-36022](https://insights.sbomify.com/CVE-2021-36022/): Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36024](https://insights.sbomify.com/CVE-2021-36024/): Magento Commerce Improper Neutralization of Special Elements Used In A Command (critical 9.1)
- [CVE-2021-36025](https://insights.sbomify.com/CVE-2021-36025/): Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36028](https://insights.sbomify.com/CVE-2021-36028/): Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36029](https://insights.sbomify.com/CVE-2021-36029/): Magento Commerce Improper Authorization Vulnerability Could Lead To Remote Code Execution (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36033 and fix it if it is affected.

What it is: CVE-2021-36033 is a critical vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36033 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36033/ (Markdown: https://insights.sbomify.com/CVE-2021-36033/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36033
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36033
- OSV: https://osv.dev/vulnerability/CVE-2021-36033

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36033/
Summaries are generated and may contain mistakes; the official description above is the record.
