CVE-2021-36044 Magento Commerce GraphQL Improper Input Validation Could Lead To Denial Of Service
An unauthenticated attacker can cause a server-side denial of service in Magento Commerce by abusing improper input validation in GraphQL fields.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-36044?
CVE-2021-36044 is a high-severity denial of service vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field.
Weakness: CWE-20
Which versions are affected by CVE-2021-36044?
8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | None |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | All versions | 2.3.7-p1 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
magento/community-edition Packagist | From 2.4.2-p1 | 2.4.2-p2 |
2 more packages
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
magento/project-community-edition Packagist | All versions to 2.0.2 | None |
Products include Adobe Adobe Commerce, Adobe Magento Open Source.
How do I fix CVE-2021-36044?
Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2021-36044 being exploited?
There is no known exploitation of CVE-2021-36044 in the wild and no public exploit code.
Other vulnerabilities in Adobe Magento Commerce
- CVE-2021-36022 Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36024 Magento Commerce Improper Neutralization of Special Elements Used In A Command
- CVE-2021-36025 Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution
- CVE-2021-36028 Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution
- CVE-2021-36029 Magento Commerce Improper Authorization Vulnerability Could Lead To Remote Code Execution
Sources
Also known as GHSA-wr57-3h2f-3q95.