# CVE-2021-36044: Magento Commerce GraphQL Improper Input Validation Could Lead To Denial Of Service

> An unauthenticated attacker can cause a server-side denial of service in Magento Commerce by abusing improper input validation in GraphQL fields.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Sep 2021
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wr57-3h2f-3q95

## What is CVE-2021-36044?

CVE-2021-36044 is a high-severity denial of service vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Magento Commerce versions 2.4.2 (and earlier), 2.4.2-p1 (and earlier) and 2.3.7 (and earlier) are affected by an improper input validation vulnerability. An unauthenticated attacker could abuse this vulnerability to cause a server-side denial-of-service using a GraphQL field.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-36044?

8 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | None |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | All versions | 2.3.7-p1 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento/community-edition` | Packagist | From 2.4.2-p1 | 2.4.2-p2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Adobe Commerce, Adobe Magento Open Source.

## How do I fix CVE-2021-36044?

Upgrade magento/community-edition to a fixed version for your release line: 2.3.7-p1 or 2.4.2-p2.

## Is CVE-2021-36044 being exploited?

There is no known exploitation of CVE-2021-36044 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Magento Commerce

- [CVE-2021-36022](https://insights.sbomify.com/CVE-2021-36022/): Magento Commerce Widgets Update Layout XML Injection Vulnerability Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36024](https://insights.sbomify.com/CVE-2021-36024/): Magento Commerce Improper Neutralization of Special Elements Used In A Command (critical 9.1)
- [CVE-2021-36025](https://insights.sbomify.com/CVE-2021-36025/): Magento Commerce Customer Edition Improper Input Validation Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36028](https://insights.sbomify.com/CVE-2021-36028/): Magento Commerce XML Injection Vulnerability Could Lead To Remote Code Execution (critical 9.1)
- [CVE-2021-36029](https://insights.sbomify.com/CVE-2021-36029/): Magento Commerce Improper Authorization Vulnerability Could Lead To Remote Code Execution (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36044 and fix it if it is affected.

What it is: CVE-2021-36044 is a high-severity denial of service vulnerability in Adobe Magento Commerce, published on 1 Sep 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36044 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; no fix listed
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected all versions; fixed in 2.3.7-p1
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento/community-edition (Packagist): affected from 2.4.2-p1; fixed in 2.4.2-p2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36044/ (Markdown: https://insights.sbomify.com/CVE-2021-36044/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36044
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36044
- OSV: https://osv.dev/vulnerability/CVE-2021-36044

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36044/
Summaries are generated and may contain mistakes; the official description above is the record.
