# CVE-2021-36088: Use after free in n/a

> A double free vulnerability in Fluent Bit allows attackers to cause denial of service or potentially execute arbitrary code.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-fluent-bit-2021-36088, GHSA-89w3-2j93-4g79

## What is CVE-2021-36088?

CVE-2021-36088 is a critical use after free vulnerability in n/a, published on 1 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Fluent Bit (aka fluent-bit) 1.7.0 through 1.7.4 has a double free in flb_free (called from flb_parser_json_do and flb_parser_do).

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2021-36088?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 1.7.0 | 1.7.5 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2021-36088?

Upgrade fluent-bit to 1.7.5 or later.

## Is CVE-2021-36088 being exploited?

There is no known exploitation of CVE-2021-36088 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)
- [CVE-2021-46879](https://insights.sbomify.com/CVE-2021-46879/): Memory corruption in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-36088 and fix it if it is affected.

What it is: CVE-2021-36088 is a critical use after free vulnerability in n/a, published on 1 Jul 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-36088 in the wild and no public exploit code.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 1.7.0; fixed in 1.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-36088/ (Markdown: https://insights.sbomify.com/CVE-2021-36088/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-36088
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-36088
- OSV: https://osv.dev/vulnerability/CVE-2021-36088

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-36088/
Summaries are generated and may contain mistakes; the official description above is the record.
